Ticket #3364 (closed Bug: duplicate)

Opened 6 years ago

Last modified 6 years ago

Pressing enter at the end of a bulleted list does not end the list

Reported by: highjinx_53 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0 Beta
Keywords: Cc:

Description

When creating a bulleted list, if the cursor is at the end of the list on a new item and enter is pressed, a new bullet is created instead of ending the list. For example:

 * Item 1
 * Item 2
 * | <-- Cursor here. Enter pressed.

Instead of ending the list:

 * Item 1
 * Item 2
| <-- Cursor here.

A new bullet is created:

 * Item 1
 * Item 2
 *  
 * | <-- Cursor here.

This can be consistently reproduced with the nightly samples.

Change History

comment:1 in reply to: ↑ description Changed 6 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to invalid

Replying to highjinx_53: The correct way of leaving list should be the following instead:

 * Item 1
 * Item 2
 * | <-- Press '''Backspace'''

Now CKEditor works in this way in IE but not Firefox, it will be fixing by introducing the 'Backspace' key behavior later.

comment:2 Changed 6 years ago by garry.yao

BTW, it's a CKEditor feature to use 'Decrease Indent' command to degrade/remove a list item just like 'Backspace' keystroke, which works well in all browser.

comment:3 in reply to: ↑ description Changed 6 years ago by garry.yao

  • Status changed from closed to reopened
  • Resolution invalid deleted

Sorry, it's my mistake, we need this feature, it will be fixed at #3312.

comment:4 Changed 6 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to duplicate

Duplicate of #3312.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy