Opened 6 years ago

Closed 6 years ago

#3438 closed Bug (fixed)

Floating panels are off by (-1px, 0px) in RTL mode.

Reported by: martinkou Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Floating Panel Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description

To reproduce:

  1. Add config.language = 'ar'; in config.js to get an RTL UI.
  2. Open replacebyclass.html in Firefox, Safarai, Opera or IE.
  3. Open any floating panel - e.g. the font combo box.
  4. The floating panel is opened 1px off to the left from its intended position.

Attachments (1)

3438.patch (1.8 KB) - added by tobiasz.cudnik 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

comment:3 Changed 6 years ago by tobiasz.cudnik

  • Keywords Confirmed added

Changed 6 years ago by tobiasz.cudnik

comment:4 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review? added

comment:5 Changed 6 years ago by garry.yao

  • Keywords Review+ added; Review? removed

Let's take this as a temporary fix while the real bug may keep hiding inside the 'CKEDITOR.element::getDocumentPosition'.

comment:6 Changed 6 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4173].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy