Ticket #3482 (closed Bug: invalid)

Opened 5 years ago

Last modified 2 years ago

Images and File References Lost

Reported by: kuntergunt Owned by:
Priority: High Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc:

Description

I have the Turnkey Mediawiki 8.10 running in VMware. I habe FF 3.0 on Ubuntu 9.04 on the Frontend. I had this problem with the FCKEditor provided but I upgraded to 2.6.4 and the problem is still there.

I put an image into my page.

test1

<br> [[Image:MyDok_-_DD_Newsletter.png]]<br>

I reedit the the page, the image is still there. After I save this is what i get:

test1

<br> [[Image:]]

If I add a caption it will result in [[Image:|TestImage]]. If I add the picture, edit for the second time with the picture still there and click wikitext the picture is gone. I also tried it with uploaded files, same problem. I also tried to have more than one title on the page, each one has an image and I edit only one title, not the whole page. In this case only the image of the edited section gets lost. I also tried a webkit (safari, google chrome) based browser (arora) and got the same result.

Attachments

LocalSettings.php.tw.txt (6.7 KB) - added by tidewater 4 years ago.
Configuration file for mediawiki where the image filename is lost when switching in-out of RichText mode

Change History

comment:1 Changed 5 years ago by kuntergunt

I now tried IE7 and got a weird result: For some reason the image went into the title and got lost after saving.

[[Image:]]test1

comment:2 in reply to: ↑ description Changed 5 years ago by arczi

  • Keywords WorksForMe Pending added; image lost removed

I was unable to reproduce this bug. Could you please test it here: http://mediawiki.fckeditor.net/index.php?title=3482&action=edit and tell us the results. Could you also provide some more information (i.e. changes in configuration files)?

comment:3 Changed 5 years ago by kuntergunt

  • Keywords WorksForMe Pending removed

I just tried the new Tunrkey Mediawiki Live CD version 2009.04. It comes with FCKeditor 2.6.4. Same thing, references to images get lost when reediting the page.

comment:4 Changed 5 years ago by Leapfrog

Same issue here

I am also running Turnkey though i am running on an installed system not live cd .

I have also tried manually replacing the fck extention manually to see if that helped however it didn't seem to make any change at all

comment:5 Changed 4 years ago by yellowbluebus

I have the same problem. This ticket was opened 8 months ago.

Has anyone found a solution by now? If so please advise. Kuntergunt and/or Leapfrog - any feedback would be highly appreciated.

It seems to be a rare problem and I can't find any info in the web.

comment:6 Changed 4 years ago by abel406

I have the same problem. I am using mediawiki 1.15.1 and the same thing occurs to the users of my site. does anyone have a clue about what happens when the user switch from default editor to rich editor ? In that moment the caption of the image desapear. I tried the link above

I was unable to reproduce this bug. Could you please test it here: http://mediawiki.fckeditor.net/index.php?title=3482&action=edit and tell us the results. Could you also provide some more information (i.e. changes in configuration files)?

and it worked fine but with mediawiki 1.11.2. i need it to work in my version wich is 1.15.1 thanks

comment:7 follow-up: ↓ 8 Changed 4 years ago by tidewater

Hi, I've run into the same issue on the implementation that we put together. That is, an enable/disable of the Rich Text view deletes the image file properties.

Was there a resolution found to this or do I have to see about getting the configuration file changes?

Changed 4 years ago by tidewater

Configuration file for mediawiki where the image filename is lost when switching in-out of RichText mode

comment:8 in reply to: ↑ 7 Changed 4 years ago by tidewater

Replying to tidewater:

Hi, I've run into the same issue on the implementation that we put together. That is, an enable/disable of the Rich Text view deletes the image file properties.

Was there a resolution found to this or do I have to see about getting the configuration file changes?

Attaching file localsettings.php.tw.txt to show the configuration file. There are several other addins.

Anyone know of config issues or that can post a known working config (maybe from ( http://mediawiki.fckeditor.net/index.php?title=3482&action=edit) to compare)?

Also, Running mediawiki v1.15.2 (anyone know the version of the test page)?

comment:9 Changed 4 years ago by tidewater

Through some trial and error found that the following inclusion in LocalSettings.php of MediaWiki was causing the images to disappear on our system when switching in/out of rich text mode:

$wgUseTidy = true;

Commenting out this line resulted in the images no longer being lost. There is discussion on the following page about $wgUseTidy and configuration files although I'm not sure if this is a final solution that allows it to be enabled.

http://www.mediawiki.org/wiki/Manual_talk:$wgUseTidy

comment:10 Changed 3 years ago by Alfred

If you write into texteditor [[image:foo.png|link=testpage]] and switch to editor and switch back link=tespage are replace with : [[image:foo.png|foo.png]]
use :
mediawiki 1.16.5 | mediawiki 1.17.0
FCKeditor :
last snapshot ( http://upload.wikimedia.org/ext-dist/FCKeditor-MW1.16-r69707.tar.gz )
last svn version have the same bug ( rev 93705 )

comment:11 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy