Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#350 closed Bug (fixed)

FF: <marquee> appends <p>&nbsp;</p> to the output

Reported by: williamsn Owned by:
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version: FCKeditor 2.4.1
Keywords: Confirmed Firefox Cc:

Description

There was a previous ticket regarding Firefox ignoring the IgnoreEmptyParagraphValue and putting

<p>&nbsp;</p>

whenever there was whitespace. We are encountering a similar, though likely unrelated problem, in the version that this bug was supposedly fixed in. Firefox ISN'T putting the empty paragraph tags in empty space, which is good. It's not supposed to. However there's an exception to this. If you use the marquee tag within the FCKeditor, it puts the empty paragraph tags before and after it. For example, we put in the following code into the FCKeditor:

<marquee scrollamount="4"><font size="4" color="#808000"><strong>Welcome!&nbsp; <a href="http://www.somewebsite.com">Click Here to ask about our Event Sponsorship Opportunities!</a></strong></font></marquee>
<p>Just some test text<br />
Hello?<br />
<br />
Okay</p>
<table width="400" cellspacing="1" cellpadding="1" border="0" align="center">
    <tbody>
        <tr>
            <td>Hello?</td>
            <td>Maybe</td>
        </tr>
        <tr>
            <td>Okay</td>
            <td>Sweet</td>
        </tr>
        <tr>
            <td>Well</td>
            <td>let's see</td>
        </tr>
    </tbody>
</table>

and, upon saving our changes to the database and coming back to the page, it turned it into this:

<p>&nbsp;</p>
<marquee scrollamount="4"><font size="4" color="#808000"><strong>Welcome!&nbsp; <a href="http://www.somewebsite.com">Click Here to ask about our Event Sponsorship Opportunities!</a></strong></font></marquee>
<p>&nbsp;</p>
<p>Just some test text<br />
Hello?<br />
<br />
Okay</p>
<table width="400" cellspacing="1" cellpadding="1" border="0" align="center">
    <tbody>
        <tr>
            <td>Hello?</td>
            <td>Maybe</td>
        </tr>
        <tr>
            <td>Okay</td>
            <td>Sweet</td>
        </tr>
        <tr>
            <td>Well</td>
            <td>let's see</td>
        </tr>
    </tbody>
</table>

This ONLY happens in Firefox (any version). It does not happen in Internet Exploder. We DO have version 2.4.1, which supposedly fixed the problem with FF and IgnoreEmptyParagraphValue. We could upgrade to 2.4.2 (and may soon), but according to "What's News", the only thing fixed in 2.4.2 was a problem with UTF, so I doubt that would fix this problem.

We are aware that the marquee tag is no longer supported in HTML specifications, but we thought it might indicate a problem somewhere and still be fixable, regardless of this lack of marquee support, and especially since it only happened in Firefox, so we thought we should submit this ticket.

Thanks,

Nicholas

Change History (3)

comment:1 Changed 10 years ago by fredck

  • Keywords Confirmed Firefox added; paragraph IgnoreEmptyParagraphValue removed
  • Milestone changed from FCKeditor 2.4.3 to FCKeditor 2.5
  • Summary changed from FCK2.4.1: FireFox violates IgnoreEmptyParagraphValue = true when marquee tag in source to FF: <marquee> appends <p>&nbsp;</p> to the output

Confirmed with FF2. No problem with IE6.

If has nothing to do with IgnoreEmptyParagraphValue. The problem is that <marquee> is an inline element in IE, while in Firefox it is a block element.

As <marquee> is a "use at your own risk" element, we could force it to behave as a block element (internally I mean).

comment:2 Changed 10 years ago by fredck

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [246].

Click here for more info about our SVN system.

comment:3 Changed 10 years ago by fredck

  • Milestone changed from FCKeditor 2.5 to FCKeditor 2.4.3
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy