Ticket #3510 (closed Bug: invalid)

Opened 5 years ago

Last modified 2 years ago

single quote text with italic face create problem

Reported by: mitulkoradia Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

I am using mediawiki 1.11 with latest FCK editor plugin.

If we have add any sentance in single quote with italic face. it will treted at bold face.

Eg: Input text:

'''This is italic'''

Output text

<b>This is italic</b>

Expected text:

'<i>This is italic</i>'

The problem is because of the "code" for bold in medeawiki is [\'\'\'] and italic is [\'\']. If we can provide something like on key press with special character. we can convert it to HTML code like ' with &lsquo; " with &ldquo;

Change History

comment:1 Changed 5 years ago by arczi

  • Keywords Confirmed added

To reproduce paste

'''This is italic'''

in WYSIWYG mode and click Source button 3 times.

This bug exists even without FCKeditor but we should have a solution for it.

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy