Ticket #3672 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

[IE] Dialogs flicker when displaying

Reported by: damo Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

When dialogs are opened for the first time, they load and display correctly. On subsequent invocations of a dialog, the whole window is blanked out while the dialog displays. The worst case seems to be on IE6; the delay can last more than a second, while the whole window remains blank.

The effect seems more pronounced when the editor is embedded within a larger application, but is still noticeable in the samples.

Attachments

3672.patch (5.7 KB) - added by tobiasz.cudnik 6 years ago.
3672_2.patch (6.8 KB) - added by tobiasz.cudnik 6 years ago.

Change History

comment:1 Changed 6 years ago by tobiasz.cudnik

  • Keywords Confirmed added

comment:2 Changed 6 years ago by tobiasz.cudnik

  • Status changed from new to assigned
  • Owner set to tobiasz.cudnik

comment:3 Changed 6 years ago by tobiasz.cudnik

  • Keywords Pending added

Please try the newest trunk, in which there is a new skin and many editor's layout structures have been changed. I cant reproduce white screen on newest trunk, while i can on older, before merging of #3503.

comment:4 Changed 6 years ago by damo

I have tried on today's nightly build (http://nightly.ckeditor.com/3668/_samples/ajax.html). The effect is still noticeable.

To reproduce, open the nightly sample in IE6 and once the editor has been created, click on the Smiley dialog. Notice that it loads properly the first time and that the editor does not disappear. Close the dialog and open it again, this time when the dialog opens the whole page goes blank for a fraction of a second. Sometimes this "fraction of a second" can go beyond a second.

Tested on Win XP, IE 6.

Changed 6 years ago by tobiasz.cudnik

comment:5 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review? added; Pending removed

I was able to reproduce this issue once again when i've switched examples back to strict mode.

Attached patch caches cover element (which caused problems, mostly in IE) so it's much faster when opening dialog second time. Gains time also when opening other dialogs after first one and on all browsers.

comment:6 Changed 6 years ago by martinkou

  • Keywords Review- added; Review? removed

The coverElement variable is actually a div, so all calls to coverElement.getFrameDocument() are invalid. The iframe is the first child inside the coverElement.

Changed 6 years ago by tobiasz.cudnik

comment:7 Changed 6 years ago by tobiasz.cudnik

  • Keywords Review? added; Review- removed

You right Martin, uploaded a correct patch.

comment:8 Changed 6 years ago by martinkou

  • Keywords Review+ added; Review? removed

comment:9 Changed 6 years ago by tobiasz.cudnik

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [3689].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy