Opened 8 years ago

Closed 2 months ago

Last modified 2 months ago

#3756 closed Bug (wontfix)

[IE7] Inconsistent navigation issue on tables with headers

Reported by: damo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM IE Cc:

Description

To reproduce:

  1. Create a table and select Headers : First Row
  2. Place cursor in first cell.
  3. Move through table with right arrow.

RESULT
Focus moves from 1st row to the 2nd row and then traverses the cells. Never moves into other cells in the first row. Same happens if you choose Headers : First Column

Same issue when navigating from outside the table into the table, the cursor skips the header cells.

Change History (6)

comment:1 Changed 8 years ago by fredck

  • Keywords Confirmed IE added
  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

Cursor positioning is not handled by our code. It's a browser feature that's provided automatically. IE is buggy here, and we don't have much to do in this sense.

I'm postponing this ticket so we can check the options we have for this. We're not able to do that right now, because any attempt to customize the navigation keys is risky.

comment:2 Changed 8 years ago by fredck

  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

comment:3 Changed 7 years ago by fredck

  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

comment:4 Changed 7 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.x

comment:5 Changed 7 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:6 Changed 2 months ago by j.swiderski

  • Resolution set to wontfix
  • Status changed from confirmed to closed

From what I have checked this issue doesn't occur in IE11 and Edge.

IE7 is no longer supported thus I'm closing the ticket.

Last edited 2 months ago by j.swiderski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy