Opened 6 years ago

Closed 6 years ago

#3855 closed Bug (fixed)

use unminified _source files for plugins

Reported by: dschoorl Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: 3.0 RC
Keywords: Confirmed Review+ Cc:

Description

I would like to run CKEditor completely with unminified code, so it is easier to see what is going on and allow for useful debugging with Firebug. This can partially be done by including the javascript file /ckeditor/ckeditor_source.js. However, only the core files are loaded unminified from /ckeditor/_source/core, all other files are loaded minified. E.g. plugin dialog files are minified and loaded from /ckeditor/plugins/ and not from /ckeditor/_source/plugins.

It would be very helpful if the plugin files could be unminified as well and get loaded from /ckeditor/_source/plugins.

I am new to (F)CKEditor, so maybe I am missing something.

P.S. setting the global variable CKEDITOR_BASEPATH to /ckeditor/_source/ results in the core files not being found.

Attachments (3)

3855.patch (438 bytes) - added by garry.yao 6 years ago.
3855_2.patch (3.8 KB) - added by garry.yao 6 years ago.
3855_3.patch (4.1 KB) - added by wwalc 6 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 6 years ago by arczi

  • Resolution set to invalid
  • Status changed from new to closed

You can use our development version: http://dev.fckeditor.net/wiki/SVN but we don't recommend using this version on real site.

For support please use our forums: http://www.fckeditor.net/forums/

comment:2 Changed 6 years ago by dschoorl

  • Resolution invalid deleted
  • Status changed from closed to reopened

Are you saying that this feature is added in the trunk? Do I need to do anything special to work with unminified plugin sources?

comment:3 Changed 6 years ago by arczi

  • Resolution set to invalid
  • Status changed from reopened to closed

No, this is not a feature, code in SVN is "unminified" because "it is easier to see what is going on and allow for useful debugging with Firebug"

comment:4 Changed 6 years ago by fredck

  • Keywords Confirmed added
  • Milestone set to CKEditor 3.1
  • Resolution invalid deleted
  • Status changed from closed to reopened

Considering the the source version of the plugins are in the package, we should really try loading them instead.

Let's check if it's doable after the 3.0.

Changed 6 years ago by garry.yao

comment:5 Changed 6 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from reopened to new
  • Type changed from New Feature to Bug

I'm wondering if this's actually a bug which was left there...

comment:6 Changed 6 years ago by fredck

  • Keywords Review- added; Review? removed

No, %REMOVE_LINE% is the right thing to have there. Your change is now forcing the editor to "always" load plugins from source.

We need a more generic solution that could work for plugins, skins, themes, etc.

comment:7 Changed 6 years ago by wwalc

Review- but just just because we should also load skins, themes and language files from the source folder.

The fix looks good, this line should be removed by CKPackager, not CKReleaser.

Changed 6 years ago by garry.yao

comment:8 Changed 6 years ago by garry.yao

  • Keywords Review? added; Review- removed
  • Status changed from new to assigned

Pending all other packaged files.

comment:9 Changed 6 years ago by wwalc

  • Keywords Review- added; Review? removed

Almost good, it turned out that there is one more extra thing to fix: the uicolor plugin.

Changed 6 years ago by wwalc

comment:10 Changed 6 years ago by wwalc

  • Keywords Review? added; Review- removed

3855_3.patch is basically the same as 3855_2.patch, one more fix for the uicolor plugin has been added.

comment:11 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:12 Changed 6 years ago by wwalc

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4362].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy