Opened 7 years ago

Closed 7 years ago

#3864 closed Bug (fixed)

Selection problem after inserting new link

Reported by: damo Owned by: garry.yao
Priority: Must have (possibly next milestone) Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: Firefox IBM Confirmed Review+ Cc:

Description

To reproduce:

  1. Open nightly Ajax sample
  2. In a new document, add a link
  3. After the link is inserted, attempt to delete the link using backspace.

Result: the link seems uneditable until additional text is added.

Attachments (2)

3864.patch (1.8 KB) - added by garry.yao 7 years ago.
3864_2.patch (2.3 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by garry.yao

  • Keywords Confirmed added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:2 Changed 7 years ago by garry.yao

  • Component changed from General to Core : Styles
  • Keywords Firefox added
  • Priority changed from Normal to High

The problem is for Gecko only, but more generic than just the link insertion, the document is locked for modification when a insertion is following a 'New Page' command.

Reproducing Procedures

  1. Open the replace by class example page;
  2. Click on 'New Page' command to create a fresh document;
  3. Insert anything;
    • Actual Result: The whole document is locked for modification.
  4. Start to type;
    • Actual Result: The document is unlocked.

Changed 7 years ago by garry.yao

comment:3 Changed 7 years ago by garry.yao

  • Keywords Review? added

comment:4 Changed 7 years ago by garry.yao

  • Keywords Review- added; Review? removed

Two bugs:

  1. The workaround has broken non-empty document;
  2. It collapsed the empty document first line height with enterMode=BR.

Changed 7 years ago by garry.yao

comment:5 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed

comment:6 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

This is a nice hack for a Firefox bug. The following bug actually:
https://bugzilla.mozilla.org/show_bug.cgi?id=346523

Please fix the changelog entries before committing. There is an extra entry in the patch, which I believe entered there by mistake.

comment:7 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3816].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy