Opened 7 years ago

Closed 7 years ago

#3874 closed Bug (fixed)

[Safari] Paste as plain text only pastes one line of multi-line text

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IBM Confirmed Review+ Cc:

Description

To reproduce:

  1. Open nightly Ajax sample
  2. Add some lines of text
  3. Select and copy more than one line of text
  4. Use Paste as Plain Text dialog to paste the selected text

Result: Only the first line is pasted.

Expected: All text should be pasted.

Tested on Safari 3.2.2 on Win XP

Attachments (1)

3874.patch (3.0 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by garry.yao

  • Keywords Pending added

WFM, I'm unable to reproduce it.

comment:2 Changed 7 years ago by tobiasz.cudnik

Me neither. Checked on 3.2.2 win32.

comment:3 Changed 7 years ago by damo

I have just reproduced this problem.

It is important to make sure you are using the Paste as Plain Text dialog and not the Paste dialog. The Paste dialog works properly.

When using the Paste as Plain Text dialog, use CTRL+V to paste the contents of the clipboard into the dialog, this works. Then when OK is pressed, only the first line is pasted into the editor content.

This has been verified on a number of different machines with the same configuration i.e. Win XP and Safari 3.2.2

If this continues to be not reproducible by you, I will try to prepare a screencast.

comment:4 Changed 7 years ago by tobiasz.cudnik

  • Keywords Confirmed added; Pending removed
  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

I was able to reproduce it once i've really used "paste as plain text" dialog, not only pasting plain text in normal paste dialog. Sorry for misunderstanding.

Safari 4 isn't affected, nor is Chrome 2 or 3.

comment:5 Changed 7 years ago by garry.yao

  • Owner changed from tobiasz.cudnik to garry.yao
  • Status changed from assigned to new

I'll take over the ticket as discussed with Tobiasz, the bug is caused by CKEDITOR.tools.encodeHtml where line-break was replaced with HTML4 <br > tag which caused consequence parsing incorrect:

CKEDITOR.tools.encodeHtml( 'line1\nline2' ) // line<BR >line2

Changed 7 years ago by garry.yao

comment:6 Changed 7 years ago by garry.yao

  • Keywords Review? added
  • Status changed from new to assigned

comment:7 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review+ added; Review? removed

comment:8 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3802].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy