Ticket #3921 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

[IE] Container scroll issue on IE7

Reported by: tobiasz.cudnik Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: IE Confirmed Review+ Cc:

Description

Moved from forum thread.

  <div style="overflow:scroll;height:200px;">
         <p>
            <label for="editor1">
               Editor 1:</label><br/>
            <textarea cols="80" id="editor1" name="editor1" rows="10">&lt;p&gt;This is some &lt;strong&gt;sample text&lt;/strong&gt;. You are using &lt;a href="http://www.fckeditor.net/"&gt;CKEditor&lt;/a&gt;.&lt;/p&gt;</textarea>
            <script type="text/javascript">
                  CKEDITOR.replace( 'editor1' );
            </script>
         </p>
      </div>

If top container has scroll, only menu scroll but iframe imitate position fixed in ie7.

Attachments

3921.patch (2.6 KB) - added by tobiasz.cudnik 5 years ago.
3921_2.patch (2.4 KB) - added by tobiasz.cudnik 5 years ago.

Change History

comment:1 Changed 5 years ago by tobiasz.cudnik

  • Status changed from new to assigned
  • Owner set to tobiasz.cudnik

comment:2 Changed 5 years ago by fredck

  • Keywords Confirmed added

Changed 5 years ago by tobiasz.cudnik

comment:3 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review? added

Problem concerned also soureview's textarea. I've played a bit with existing IE hacks and it seems to work in IE 6 & 7 & 8 both in quirks and strict mode. I hope it wont break something else.

As it turns out, "position fixed" effect was caused by statically positioned iframe inside 2 relative position elements (one was a table). Interesting, as IE doesn't support position fixed...

comment:4 Changed 5 years ago by fredck

  • Keywords Review- added; Review? removed

I'm sure there was a reason for using position:relative there. Actually, the patch broke the source mode, if reducing the browser size so the toolbars start wrapping.

Changed 5 years ago by tobiasz.cudnik

comment:5 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review? added; Review- removed

Confirming in IE 7 strict sourcearea is too wide. In this patch i'm applying position: relative fix from sourcearea only when is source mode. Fix is removed when switching to wysiwyg mode.

comment:6 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

Ok, it looks like the changes for the WYSIWYG mode are ok. It's still pending a solution when in source mode, as the problem is still reproducible there. We'll not fix it right now though. Please open a ticket for it, for the 3.x, after committing this one.

A quick fix for this problem is by simply adding "position:relative" to the outer <div> element.

comment:7 Changed 5 years ago by tobiasz.cudnik

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [3912]. Source mode issue moved to #3970.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy