Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3994 closed Bug (fixed)

Horizontal line issue

Reported by: arczi Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: Confirmed Review+ Cc:

Description

Steps to reproduce:

  • Open replacebyclass

  • Put cursor at the end of the content
  • Insert Horizontal line ( JS error in FF3 )
  • Insert another Horizontal line

Result:

Chrome - new line was added at the beginning of the content

IE - new line was added at the end of the content

FF3 - no line due to JS error:

parentNode is null
http://localhost/edytor/CKEditor/trunk/_source/core/dom/node.js
Line 197

Attachments (1)

3994.patch (1.8 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 7 years ago by garry.yao

  • Component changed from General to Core : Styles
  • Keywords Confirmed added
  • Owner set to garry.yao
  • Status changed from new to assigned

Changed 7 years ago by garry.yao

comment:2 Changed 7 years ago by garry.yao

  • Keywords Review? added

comment:3 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:4 follow-up: Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3950].

comment:5 in reply to: ↑ 4 Changed 7 years ago by pomu0325

Replying to garry.yao:

Fixed with [3950].

Ticket# typo in commit log?

Fixing #3944: Insert horizontal line at end of document cause error.
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy