Ticket #4044 (closed Bug: fixed)

Opened 5 years ago

Last modified 22 months ago

[Opera] ALT+F10 doesn't focus the toolbar [CORE-33752]

Reported by: arczi Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.0
Keywords: Opera VendorFix IBM Cc: hallvord@…, satya_minnekanti@…

Description

ALT+F10 doesn't focus the toolbar.

Attachments

4044.patch (1.2 KB) - added by garry.yao 4 years ago.
4044_opera_bug.html (1.8 KB) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:2 Changed 4 years ago by krst

  • Status changed from new to confirmed

Confirmed on Opera 10.61.3484, CKE 3.4.1 Trunk & Demo

comment:3 Changed 4 years ago by krst

  • Version set to 3.4.1 (SVN - trunk)

comment:4 Changed 4 years ago by tobiasz.cudnik

  • Milestone set to CKEditor 3.4.2

Changed 4 years ago by garry.yao

comment:5 Changed 4 years ago by garry.yao

  • Status changed from confirmed to review
  • Owner set to garry.yao

Opera's focus get stuck when moving the focus between editable iframe and toolbar links.

comment:6 Changed 4 years ago by garry.yao

  • Status changed from review to review_failed

Now there's another serious problem now found on Opera that keystroke following ALT doesn't trigger any event ;(

comment:7 Changed 4 years ago by garry.yao

We'll need to switch our default keymap (to Ctrl prefix?) on Opera in case no workaround could be found.

comment:8 Changed 4 years ago by garry.yao

  • Cc hallvord@… added
  • Milestone CKEditor 3.4.2 deleted

After some investigation, we have no workarounds at hand on neither of the two Opera bugs here, the first patch is even not perfect enough, as #4043, toolbar buttons is not the only broken thing because of this, repeat the bugs:

  1. Moving focus from wysiwyg iframe onto any other links on the host page doesn't really blur the iframe.
  2. ALT key combination is not detectable, the later keystroke doesn't present a key event.

We'd like to have Opera employee here to give their comments

comment:9 Changed 4 years ago by hallvord@…

On alt+key - ops, will report this.. Now tracked internally as CORE-33752, targeted to be fixed as part of a general key event support rewrite due to start shortly.

comment:10 follow-up: ↓ 12 Changed 4 years ago by hallvord@…

Garry, regarding issue 1 in your comment - can you tell me what you're doing to move focus here?

Also, a comment on the suggested patch:

 // Opera requires an invisible input to 'redirect' the focus when 
 // switching focus from toolbar to editor (#4044). 

Have you tried calling document.body.focus() rather than using this input hack?

comment:11 Changed 4 years ago by garry.yao

Have you tried calling document.body.focus() rather than using this input hack?

Note that we're consistently using body focus in Opera now after #6025.

comment:12 in reply to: ↑ 10 Changed 4 years ago by garry.yao

Replying to hallvord@…:

Garry, regarding issue 1 in your comment - can you tell me what you're doing to move focus here?

We're using element::focus() on link elements. Due to recently fixed #6444 (where another Opera bug is reported), the second chunk of hack in my patch is obsoleted now.

Also, a comment on the suggested patch:

 // Opera requires an invisible input to 'redirect' the focus when 
 // switching focus from toolbar to editor (#4044). 

Have you tried calling document.body.focus() rather than using this input hack?

Changed 4 years ago by garry.yao

comment:13 Changed 4 years ago by garry.yao

@hallvord, I've uploaded normalized TC for above two Opera bugs, we would expect a sooner fix at Opera side.

comment:14 Changed 4 years ago by hallvord@…

Thanks Garry. I've now also reported these: CORE-33795 link.focus() does not remove focus from rich text editor CORE-33796 calling body.focus() on editable body from button onclick fails

comment:15 Changed 3 years ago by hallvord@…

(Both latter bugs are now fixed in Opera 11.10)

comment:16 Changed 3 years ago by hallvord@…

  • Summary changed from [Opera] ALT+F10 doesn't focus the toolbar to [Opera] ALT+F10 doesn't focus the toolbar [CORE-33752]

comment:17 Changed 3 years ago by garry.yao

Thanks for the update @hallvord, #4043 is now closed while we're still waiting for the ALT modifier key fix to land.

comment:18 Changed 3 years ago by satya

  • Keywords IBM added
  • Cc satya_minnekanti@… added

comment:19 Changed 3 years ago by garry.yao

  • Status changed from review_failed to new
  • Owner garry.yao deleted

comment:20 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from 3.4.1 to 3.0

ALT+F10 and ALT+F11 don't work on Opera 11.11

comment:21 follow-up: ↓ 23 Changed 3 years ago by garry.yao

Ticket Test: run OR view source.

comment:22 Changed 3 years ago by fredck

  • Keywords VendorFix added

comment:23 in reply to: ↑ 21 Changed 3 years ago by fredck

Replying to garry.yao:

Ticket Test: run OR view source.

While this test may be useful to check the editor behavior to the keys, it has some issues:

  • It doesn't apply to the ticket issue because the problem is that the ALT key is being blocked by Opera to reach the page. As a result, the tests is PASSing on Opera, while it should fail to be useful.
  • Currently it's not running on IE.

comment:24 Changed 2 years ago by fredck

@hallvord@opera.com, you said that this one is related to CORE-33752, which is a resolved ticket.

We're not able to confirm this fix with Opera 11.61.

I'm a bit confused now. Would you mind clarifying the status of it?

comment:25 follow-up: ↓ 27 Changed 2 years ago by hallvord@…

Hi Fred, this is a very recent fix and it isn't in 11.61. I hope it will be in O12.

As far as I know the current previews of O12 haven't picked up this fix yet - don't remember what core version latest previews use though. You can check the Presto engine version number from the UA string and compare it to information in the BTS or from the engine changelogs on http://www.opera.com/docs/specs/ to see whether it should be available.

(To find this "should the fix be available" information in the BTS, look up the master task of CORE-33752 by following the "blocks" link - it takes you to CORE-28739. Then look at the last comments to see what minor version of the engine it has been "integrated" in. This is not really obvious to outsiders, sorry about that ;-))

This particular fix needs a bit of adjustment in Desktop's platform-specific code because key input works differently on Mac/Win/nix/others, so they need to do a bit of work before it's all tied together.

comment:26 Changed 2 years ago by hallvord@…

(AFAIK this fix will be in Presto 2.11.295 and later, by the way..)

comment:27 in reply to: ↑ 25 Changed 2 years ago by fredck

Replying to hallvord@…: Cool. Thanks for the details. I look forward to seeing this on O12.

Last edited 2 years ago by fredck (previous) (diff)

comment:28 Changed 2 years ago by satya

I could still reproduce this issue in Opera12

comment:29 Changed 2 years ago by hallvord@…

Try in a 12.50 preview? The keyboard changes were held back a bit.

comment:30 Changed 22 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

Since 12.50 is now known as 12.10 and this is current version of Opera I can confirm that alt+F10 works as expected. Toolbar gains focus.

Thank you hallvord@…

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy