Opened 7 years ago

Closed 7 years ago

#4092 closed Bug (fixed)

[IE6] Close button missing for dialog without multiple tabs

Reported by: garry.yao Owned by: tobiasz.cudnik
Priority: Normal Milestone: CKEditor 3.0
Component: UI : Dialogs Version:
Keywords: IE Confirmed Review+ Cc:

Description

The close button was not visible when open a dialog which has only one tab.

Reproducing Environment

  • IE6/Windows XP SP2
  • Standard Mode
  • LTR document direction

Attachments (4)

IE6.png (4.8 KB) - added by garry.yao 7 years ago.
Screenshot of IE6
4092.patch (5.7 KB) - added by garry.yao 7 years ago.
2009-07-27-115510_1408x1080_scrot.png (95.5 KB) - added by tobiasz.cudnik 7 years ago.
IE6 (not affected)
4092_2.patch (1.6 KB) - added by tobiasz.cudnik 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by garry.yao

Screenshot of IE6

comment:1 Changed 7 years ago by tobiasz.cudnik

Can't reproduce it.

Changed 7 years ago by garry.yao

comment:2 Changed 7 years ago by garry.yao

  • Keywords Confirmed added

Fred's confirmed it.

comment:3 Changed 7 years ago by garry.yao

  • Keywords HasPatch added

The close button's incorrect position in IE6 is due to the following rules which is supposed to be apply to only IE7 quirks only:

/* IE7 + IE quirks */
.cke_skin_kama .cke_browser_ie7.cke_single_page .cke_dialog_contents
{
	float: left;
}

It's shown that the dialog style css is still containing multiple classes selectors which is not fixed by #3021. Proposing for changing it, but maybe breaking Tobias' hacks for IE7 RTL at several places, could you please help to verify the patch?

comment:4 Changed 7 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Changed 7 years ago by tobiasz.cudnik

IE6 (not affected)

Changed 7 years ago by tobiasz.cudnik

comment:5 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review? added; HasPatch removed

Although splitting DOM structure to keep each important class in separate node is highly desired, doing this right now is very dangerous and maybe even time-wasting as dialog layout is going to be re-written.

I'm still unable to reproduce this issue on my IE6 (screenshot attached), but simple patch i'm providing should resolve this issue (as long as quoted css rule is the reason).

comment:6 Changed 7 years ago by garry.yao

  • Keywords Review+ added; Review? removed

comment:7 Changed 7 years ago by tobiasz.cudnik

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3982].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy