Opened 7 years ago

Closed 7 years ago

#4129 closed Bug (fixed)

[FF] Unable to remove list with Ctrl-A

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Lists Version:
Keywords: Confirmed Review+ Cc:

Description

Reproducing Procedures

  1. Open the 'replace by class' sample page in Firefox;
  2. Load the document with the following content and selection with Ctrl-A:
    [<p>line1</p>
    <p>line2</p>]
    
  3. Click on 'Insert/Remove Bulleted List' button twice;
    • Actual Result: The second click of remove list has no effect.

Attachments (2)

4129.patch (2.8 KB) - added by garry.yao 7 years ago.
4129_2.patch (5.4 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by tobiasz.cudnik

  • Keywords Confirmed added
  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

Changed 7 years ago by garry.yao

comment:2 Changed 7 years ago by garry.yao

  • Keywords Review? added
  • Owner changed from tobiasz.cudnik to garry.yao
  • Status changed from assigned to new

After discussing with Tobias, I'm taking over this ticket.

comment:3 Changed 7 years ago by tobiasz.cudnik

  • Keywords Review- added; Review? removed

Removing list works after second list-command with the patch, but after third one nothing is happening. Expected is that list will be created again.

comment:4 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed
  • Status changed from new to assigned

I'm trying to persuade that this patch's not being a drastic change:

  1. Changes in previous 4129.patch are leveraged without change.
  2. Changes to _source/plugins/wysiwygarea/plugin.js and _source/core/dom/element.js are because it's breaking the 'selectionChange' event

which stop the list command from freshing( Tobias's comment );

  1. Changes to _source/plugins/domiterator/plugin.js are necessary clean up to avoid extra list item ( contain only whitespace text ) been created when exec list command multiple times.

Changed 7 years ago by garry.yao

comment:5 Changed 7 years ago by tobiasz.cudnik

I can confirm that issues i've mentioned is fixed with second patch.

comment:6 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:7 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4034].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy