Opened 7 years ago

Closed 7 years ago

#4143 closed Bug (fixed)

plugins/domiterator TCs is breaking

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.0
Component: Core : Styles Version:
Keywords: Confirmed Cc:

Description

  1. 'test_iterator_pseudoBlock' is broken because of TC is incorrectly written
  2. 'test_iterator_establish_paragraph' shows a bug within CKEDITOR.dom.range where the element id is not preserved when extracting contents.

Attachments (1)

4143.patch (2.8 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by garry.yao

comment:1 Changed 7 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:2 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:3 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4014] and [4015].

comment:4 Changed 7 years ago by garry.yao

  • Keywords Review+ removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

test_extractContents series TCs are broken in "CKEDITOR.dom.range" because of [4014].

comment:5 Changed 7 years ago by fredck

  • Resolution set to fixed
  • Status changed from reopened to closed

Please open a dedicated ticket for regressions.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy