Ticket #4228 (closed New Feature: fixed)

Opened 5 years ago

Last modified 3 years ago

V3: Support for toolbar location "out" and toolbar sharing

Reported by: fredck Owned by: fredck
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Toolbar Version:
Keywords: Cc: mike@…, bernesto@…

Description

Just like V2, it should be possible to set the toolbar location to somewhere outside the editor space, as well as share that same toolbar among several editor instances.

Attachments

4228.patch (34.9 KB) - added by garry.yao 4 years ago.
shared_spaces_iframe.patch (20.7 KB) - added by fredck 4 years ago.
Initial patch for the frames support.
shared_spaces_iframe 3.4.3.patch (17.8 KB) - added by bernesto 3 years ago.
3.4.3 IFrame out patch

Change History

comment:1 Changed 4 years ago by n8behavior

  • Cc mike@… added

we are migrating a customer of our to CKEditor and need this feature. i am going to be doing this quickly in our SVN/trac system. if you would like to view/use my changes you may do so here

http://trac.lis.n8scm.net/ticket/10

Changed 4 years ago by garry.yao

comment:2 Changed 4 years ago by garry.yao

  • Owner set to garry.yao
  • Keywords Review? added
  • Status changed from new to assigned

Manual TCs added at : http://ckeditor.t/tt/4228/1.html

comment:3 Changed 4 years ago by n8behavior

awesome garry! can you tell me what version this patch was created against? also the link for TCs is broken. tx!

comment:4 Changed 4 years ago by fredck

#4730 has been marked as DUP.

comment:5 Changed 4 years ago by fredck

  • Keywords Review- added; Review? removed
  • Status changed from assigned to new
  • Owner changed from garry.yao to fredck

comment:6 Changed 4 years ago by fredck

  • Keywords Review? added; Review- removed
  • Status changed from new to assigned

I've created a branch in the SVN for this feature:
http://svn.fckeditor.net/CKEditor/branches/features/sharedspaces/

The proposed approach is complete different now. The feature is not anymore called "toolbar out", but instead "shared spaces". This because with this new way we don't care what is really rendered in the top of toolbar. We may have a toolbar there, but can also have other things. For example, it's not possible to share also the elements path. A dedicated sample has been included to illustrate it.

There is a limitation though. It's not possible to share spaces in elements that are in other frames. This limitation is not really related to the approach we use in the branch, but it's caused by the way we handle skins and floating elements in V3.

We should go ahead with it in the way we have in the branch for now, which gives the necessary flexibility related to this feature. We can then listen for feedback from our community after the release to understand whether the frames support is really needed and then investigate solutions for it.

comment:7 Changed 4 years ago by garry.yao

  • Keywords Review- added; Review? removed

Two issues found:

  1. Please populate the changes to other skins as well;
  2. The following css rules change has broken the toolbar collapser ( by rendering the toolbox as invisible ):

http://dev.fckeditor.net/changeset/4644/CKEditor/branches/features#file6

comment:8 Changed 4 years ago by fredck

  • Keywords Review? added; Review- removed

Both issues fixed in the feature branch.

comment:9 Changed 4 years ago by garry.yao

  • Keywords Review+ added; Review? removed

comment:10 Changed 4 years ago by fredck

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [4653].

Changed 4 years ago by fredck

Initial patch for the frames support.

comment:11 Changed 4 years ago by fredck

I'm attaching here, for reference, an initial patch to bring frames support for this feature. It's not perfect though, and may break things in specific situations (e.g. when creating a simple editor instance inside an iframe and opening a dialog).

comment:12 Changed 4 years ago by httpete

I applied this shared_spaces_iframe.patch, but it does not work. Not in the sample iframe you supply in the patch either. I need this feature, otherwise I am stuck on fck forever and my clients want it. Is it far off?

comment:13 Changed 4 years ago by fredck

We would hardly have this feature anytime soon. I would instead recommend you to review the way you share the toolbar, avoiding using iframes.

comment:14 Changed 4 years ago by httpete

fredck thanks - but your patch seems so close. Something must be slightly off. I need to be able to render the page the user is editing inside a frame so that the styles from my wrapper application don't bleed into the rendered page that is being edited. I can't think of another way to accomplish this without frames.

comment:15 Changed 4 years ago by dinu

Hi, So what's the real status for this? I see it didn't make it into trunk. I really depend on this working in just the way the patch is -supposed to- work: toolbar shared in parent window.

Dinu

comment:16 Changed 4 years ago by dinu

I thought I managed to adapt the iframe patch; however, like you said, the dialog is all messed up. Is there really no way to expedite this? It's the only thing that hangs me on V2

comment:17 Changed 4 years ago by garry.yao

Note that we will NOT provide iframe-based shared space in CKEditor, we're leaving it an opportunity in v2 mainly due to the global pollution in the past, but now CKE is namespaced, isolated from the rest of your app, so hanging up the new version just because of this iframe soup isn't wise, alternative to iframe has always been an highly valuable topics nowadays.

comment:18 Changed 4 years ago by dinu

This is sad news, because the alternative is even more messy...

comment:19 Changed 3 years ago by Ciantic

Does CKEditor support shared toolbar, or not? I could not figure out what was the fight about iframes, I only need to have several editable boxes (I don't care are they iframe or not) with one toolbar.

comment:20 Changed 3 years ago by bernesto

  • Cc bernesto@… added
  • Keywords iframe toolbar out shared spaces added; Confirmed Review+ removed
  • Version set to 3.4.3 (SVN - trunk)

I think the toolbar out feature for frames is very necessary. For many projects, just "don't use IFrames" is not an option. For us we use a static UI in the parent frame and load pages to be edited into the IFrame. This results in a better experience for our users.

We are new to CKEditor, but have been using FCKeditor for years. It was trivial to get Fred's patch working properly, so I just completed it and updated it to 3.4.3. (See attached patch).

There are a few areas that could be improved since we are new to this project, and we will do so as time permits, unless some one beats us to it :-)

Areas to improve:

  1. There should be a reference to the document containing the toolbar in the toolbar to use for positioning elements like float panels. Currently we are just creating the reference as needed.
  2. The toolbar should be a reference that the attached editor can reference and thereby the window of the toolbar for positioning elements.

Again, we are new to this project, so if these already exist, let us know. But, let's keep this moving forward and maybe this may get included in a future release.

  • Brian

Changed 3 years ago by bernesto

3.4.3 IFrame out patch

comment:21 Changed 3 years ago by fredck

  • Keywords iframe toolbar out shared spaces removed
  • Version 3.4.3 (SVN - trunk) deleted

@bernesto, thanks for the contribution.

Considering that this ticket is closed, I recommend you opening a new ticket for this specific feature, attaching your patch there and making a reference to it here (and to this one there). In this way it may have more attention.

I can't tell you we'll have this feature by default, but at least having a maintained working patch for it is an option for those who need it.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy