Ticket #4256 (closed New Feature: wontfix)

Opened 5 years ago

Last modified 21 months ago

Enable impersonation in aspx file browser connector

Reported by: rheinig Owned by:
Priority: Normal Milestone:
Component: Server : ASP.Net Version: FCKeditor 2.6.3
Keywords: HasPatch Cc:

Description

I needed the folder view, folder creation and upload to use the proper windows domain credentials of the client.

My implemetation is attached - the zip contains only files changed from the FCKeditor.net 2.6.3 or FCKeditor 2.6.4.1 sources.

Note there are core changes only because I found upload error handling to be defective. The new handling is far from perfect, I just "made it work for me".

For further information, please see the readme_rh.html file included in the attachment and do a diff - most should be pretty obvious.

If you wish to include this in your product, I'm perfectly willing to fully pass my rights on to you, but as I have developed this on company time, please ask first.

Attachments

FCKeditor.Net_2.6.3_rh.zip (37.9 KB) - added by rheinig 5 years ago.

Change History

Changed 5 years ago by rheinig

comment:1 Changed 5 years ago by rheinig

Sorry, seems like I posted a bit prematurely. My code works as designed, but I did overlook that there is more than one place to upload files. Going into the server browser and *then* uploading is handled, uploading directly from the 'upload' tab in e.g. the image dialog hangs. Will look into that later.

comment:2 Changed 5 years ago by fredck

  • Keywords HasPatch added; Impersonation removed

comment:3 Changed 5 years ago by alfonsoml

Thank you for your contribution

This is not any kind of official response or statement, but given your warning about the rights of the code that you have added, I think that in order to avoid misunderstandings you should verify with your company that we can use the code and then sign the cla so that there's no risk about looking at it.

Imagine that you move away and after sometime some similar code is added to the file manager, then some stupid lawyer from your company sees that and sues CKSource because there is this ticket with some code that proposed something similar.

comment:4 Changed 5 years ago by fredck

@rheinig, alfonsoml is right. I've giving you write permissions to the CLA page. I would ask you to please sign it so we can eventually use your code. Thanks!

comment:5 Changed 21 months ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to wontfix

FCKeditor was retired and is no longer supported but perhaps such feature could be installed in CKFinder? Unfortunately I don't see any note about CLA thus closing the ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy