Ticket #4261 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

JAWS reads all items in Font Size drop down box as "8 Link" in "office2003" skin

Reported by: Pranav Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.2
Component: Accessibility Version: 3.0
Keywords: Confirmed Oracle Cc: Pranav Senthil

Description

Keep pressing tabs to navigate through the Font size drop down boxes. You will observe that JAWS reads all items as "8 Link"

Change History

comment:1 Changed 5 years ago by tobiasz.cudnik

  • Milestone changed from CKEditor 3.0 to CKEditor 3.1

comment:2 follow-up: ↓ 3 Changed 5 years ago by garry.yao

  • Keywords Pending added

WFM in both IE and Firefox, could please provide more details?

comment:3 in reply to: ↑ 2 Changed 5 years ago by Pranav

Replying to garry.yao:

WFM in both IE and Firefox, could please provide more details?

I think description is sufficient to replicate the problem. Can you tell me what additional details you want?

comment:4 follow-up: ↓ 5 Changed 5 years ago by tobiasz.cudnik

I can also confirm that size labels are reader correctly. This issue i'm thinking you may have is the "link" suffix which is being read with each size.

Issue details was a bit misleading, after reading them i thought that ALL sizes are read as "8" size.

comment:5 in reply to: ↑ 4 Changed 5 years ago by Pranav

Replying to tobiasz.cudnik:

I can also confirm that size labels are reader correctly. This issue i'm thinking you may have is the "link" suffix which is being read with each size.

Issue details was a bit misleading, after reading them i thought that ALL sizes are read as "8" size.

Yes, size labels are rendered properly. But each element is size drop down box is being read as "8 Link". Suppose we tab from size 8 to size 9, JAWS reads it as "8 Link" and again if we tab from size 9 to size 10, JAWS reads it as "8 Link". So your understanding that ALL sizes are being read as "8" size is perfectly okay.

comment:6 follow-up: ↓ 7 Changed 5 years ago by tobiasz.cudnik

  • Owner set to tobiasz.cudnik
  • Status changed from new to assigned

In this case i cannot confirm this issue, as i'm able to get all sizes pronounced.

I'm using following steps to reproduce it:

  • Load sample with default toolbar
  • Focus editor's content area
  • Press Alt + F10 (focus toolbar)
  • Press Shift + Tab, 6 times (focus size combo)
  • Press Space
  • Press Tab at least 2 times

Maybe some other scenario fails. Can you please try above one and provide steps which lead to failure in you case ?

I'm testing on fresh installation of JAWS.

comment:7 in reply to: ↑ 6 Changed 5 years ago by Pranav

Replying to tobiasz.cudnik:

In this case i cannot confirm this issue, as i'm able to get all sizes pronounced.

I'm using following steps to reproduce it:

  • Load sample with default toolbar
  • Focus editor's content area
  • Press Alt + F10 (focus toolbar)
  • Press Shift + Tab, 6 times (focus size combo)
  • Press Space
  • Press Tab at least 2 times

Maybe some other scenario fails. Can you please try above one and provide steps which lead to failure in you case ?

I'm testing on fresh installation of JAWS.

Well this issue is present only in "office 2003" skin...have you changed the skin to "office 2003"?

comment:8 follow-up: ↓ 9 Changed 5 years ago by tobiasz.cudnik

I've checked in IE8 and FF 3.5 using office2003 skin and @4165.

I understand that this does work for you on kama skin ?

comment:9 in reply to: ↑ 8 Changed 5 years ago by Pranav

Replying to tobiasz.cudnik:

I've checked in IE8 and FF 3.5 using office2003 skin and @4165.

I understand that this does work for you on kama skin ?

I am able to reproduce this issue consistently in nightly build also. I have uploaded a video illustrating the issue. Here is the link

http://www.youtube.com/watch?v=3f0fdX_CFIs

The browser used was IE8.

comment:10 Changed 5 years ago by tobiasz.cudnik

  • Keywords Pending removed

After deep investigation i was able to reproduce similar issue on r3758 and also latest trunk. It seems to happen on one system while other one, with same versions of OS, IE8 and JAWS is not affected.

TC

  1. Focus editor contents
  2. Press ALT+F10
  3. Navigate to font size (SHIFT+TAB, 6 times)
  4. Press ENTER or SPACE to open combo
  5. Navigate to "11" (TAB or DOWN ARROW, 4 times)
  6. Navigate to "10" (SHIFT+TAB or UP ARROW)

Result: On position with "10" (and lower ones) JAWS still articulates "11".

This looks like a JAWS issue to me. Quite similar one which i was able to reproduce randomly is repeated articulation of "Source link" (which stays for Source mode button) while pressing SHIFT+TAB to reach the combo.

I think we should check out possibilities to get more information about what's happening on the JAWS side here.

comment:11 Changed 5 years ago by tobiasz.cudnik

Possible workaround for last described issue (and possibly for the reported one) is pressing INSERT+ESC which triggers JAWS to update the screen informations.

comment:12 Changed 5 years ago by garry.yao

  • Priority changed from High to Normal
  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

comment:13 Changed 5 years ago by fredck

  • Status changed from assigned to new
  • Owner tobiasz.cudnik deleted
  • Component changed from General to Accessibility

comment:14 Changed 5 years ago by garry.yao

  • Keywords Confirmed added
  • Owner set to garry.yao
  • Status changed from new to assigned

Supposed to be fixed at [4974] with appropriate ARIA roles.

comment:15 Changed 5 years ago by garry.yao

  • Status changed from assigned to closed
  • Version set to 3.0
  • Resolution set to fixed

Fixed with [5092] on 3.2.x branch.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy