Opened 9 years ago

Closed 9 years ago

Last modified 5 years ago

#430 closed Bug (fixed)

Remove link issue when class attribute is defined

Reported by: decinz Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.2
Keywords: Confirmed Firefox Cc: niklas.nilsson@…

Description

This issue exists on Firefox 2.0.0.3. Doesn't appear to be an issue with IE7.

When a link tag with a defined class attribute is removed using the "Remove link" button, the link tag is converted to a span tag instead of being removed.

  1. To reproduce this issue, paste the following into FCKeditor's Source view:
<p>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/" class="myCssClass">FCKeditor</a>.</p>
  1. Next press the Source button to return to the normal view. Select the link in the editor area and click on the "Remove Link" button.
  1. Finally, press the Source button again and you will see that the link tag has been converted to a span tag.

Change History (4)

comment:1 Changed 9 years ago by alfonsoml

  • Keywords Confirmed added

comment:2 Changed 9 years ago by alfonsoml

  • Resolution set to fixed
  • Status changed from new to closed

I've added a testcase in [282] and a fix (manually removing the link tag) in [283]

comment:3 Changed 5 years ago by niklas.nilsson

  • Cc niklas.nilsson@… added
  • Version changed from FCKeditor 2.4.2 to 3.5.2

This issue seems to be back in CKEditor 3.5.2 / Firefox 4, verified with the testcase as well. I have reproduced the same problem with style attributes as well.

comment:4 Changed 5 years ago by alfonsoml

  • Version changed from 3.5.2 to FCKeditor 2.4.2

Please, open a new ticket.

This one was closed four! years ago in a different code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy