Opened 7 years ago

Closed 6 years ago

#4379 closed New Feature (fixed)

V3 : Paste System

Reported by: garry.yao Owned by:
Priority: Normal Milestone: CKEditor 3.1
Component: General Version:
Keywords: Umbrella Paste Cc:

Description (last modified by garry.yao)

This is an umbrella ticket. It points to several to tickets that must be completed to bring the new pasting system of CKEditor.
The new pasting features should be conducted within a dedicated branch.

Paste Auto Detect

#1427
Autodetect clipboard contents on Paste

Pasting Processor

#4395
Use htmldataprocessor to refactor pasting processor

#3828
Paste from Word - bullets not reproduced

Pasting from MS-WORD

#4423
Proper list handling including bullet and number lists from MS-Word

#4427
Proper image handling from MS-Word

#4441
Support for copying table from MS-Word

#4444
Adapting formattings from MS-Word to editor's style system

#4470
Deprecate the dialog of 'Paste from Word'

Pasting as Pain Text

#4469
Enhance 'Paste As Text'

Change History (14)

comment:1 Changed 7 years ago by garry.yao

  • Description modified (diff)

Tidied up the description a bit.

comment:2 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:3 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:4 Changed 7 years ago by garry.yao

  • Description modified (diff)
  • Keywords Paste added

comment:5 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:6 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:7 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:8 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:9 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:10 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:11 Changed 7 years ago by garry.yao

  • Description modified (diff)

comment:12 Changed 6 years ago by garry.yao

  • Description modified (diff)

comment:13 Changed 6 years ago by fredck

  • Milestone set to CKEditor 3.1

comment:14 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from new to closed

Close the umbrella ticket since all sub tickets get fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy