Ticket #4462 (closed Bug: invalid)

Opened 5 years ago

Last modified 3 years ago

fck mediawiki extension is broken under php 5.3.0

Reported by: yannh Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

Mediawiki 1.15.1 Php 5.3.0 Fck mediawiki extension_N

Change History

comment:1 Changed 5 years ago by cneubauer

It would help if this was a bit more specific, but this is probably related to the call by reference/hook issue discussed here: http://www.mwusers.com/forums/showthread.php?t=13460

comment:2 Changed 5 years ago by solweig

  • Status changed from new to closed
  • Resolution set to fixed

The problem is the php version (>= 5.3.0), just modify in file : FCKeditor.body.php

public function onCustomEditor(&$article, &$user) {

global $wgRequest, $mediaWiki;

....

by

public function onCustomEditor($article, $user) {

global $wgRequest, $mediaWiki;

....

comment:3 Changed 4 years ago by toots

  • Status changed from closed to reopened
  • Resolution fixed deleted

Could you be more specific about the changes ? According to the link above, it does seem to only be a work-around.

Also, if this a a real fix, why is it not commited in the sources then ?

I'm repoening the ticket because people keep getting this issue with the latest source (see: http://bugs.debian.org/579822).

comment:4 Changed 3 years ago by j.swiderski

  • Status changed from reopened to closed
  • Resolution set to invalid

MediaWiki and FCKEditor are no longer supported. Closing the ticked as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy