Opened 7 years ago

Closed 6 years ago

#4543 closed Bug (fixed)

Unable to move cursor between hr and table

Reported by: garry.yao Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc:

Description (last modified by garry.yao)

  1. Load an editor with the following content and selection:
    <table border="1" cellpadding="1" cellspacing="1" style="width: 200px;">
    	<tbody>
    		<tr>
    			<td>
    				text^</td>
    		</tr>
    	</tbody>
    </table>
    <hr />
    
  2. Try to move cursor after table by press 'Right Arrow' key;
  • Actual Result: It's impossible to move cursor exactly after the table and before the HR. (For IE, even worse, lots of dummp paragraph generated at the end of this document)

Attachments (2)

4543.patch (2.3 KB) - added by garry.yao 7 years ago.
4543_2.patch (3.2 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by garry.yao

  • Description modified (diff)
  • Keywords IE removed
  • Summary changed from [IE] Unable to move cursor between hr and table to Unable to move cursor between hr and table

Changed 7 years ago by garry.yao

comment:2 Changed 7 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

This patch rely on a rent fix on trunk, you need to make sure working copy is updated to [4475].

comment:3 Changed 7 years ago by fredck

  • Keywords Review- added; Review? removed
  • Milestone changed from CKEditor 3.1 to CKEditor 3.2

I don't feel any difference after the patch. We need to discuss more over this issue.

Changed 6 years ago by garry.yao

comment:4 Changed 6 years ago by garry.yao

  • Keywords Review? added; Review- removed

The bug reveals an significant defect in our auto fixing logic, due to this significance, re-targeting it to this release.

comment:5 Changed 6 years ago by fredck

  • Milestone changed from CKEditor 3.2 to CKEditor 3.1

comment:6 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:7 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4666].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy