Ticket #4668 (closed Bug: expired)

Opened 5 years ago

Last modified 5 years ago

bug on editing justified paragraphs

Reported by: chaimkeller Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending Cc:

Description (last modified by fredck) (diff)

When editing a justified paragraph using ckeditor 3.0.1 (also fckeditor, last version), any editing that will alter the justification of the first line adds spaces to the beginning of the paragraph. This ruins the justification of the paragraph.

This bug can be reproduced on all browsers that I tested (Firefox, IE, Opera) and all operating systems tested by myself including Windows Vista, Windows XP, Linux (Centos 5.2).

For example:
html before edit:

<p style="text-align: justify;">
	<span style=""><strong>Orders</strong><br />
	Please place all orders online using your account.&nbsp; A confirmation email is provided for a successful order.

Now adding a space in the middle of the word "orders" on the first line.

html after edit:

<p style="text-align: justify;">
	<span style=""><strong>Orders</strong><br />
	&nbsp;Please place all ord ers online using your account.&nbsp; A confirmation email is provided for a successful order.

Note that "&nbsp;" was added to beginning of sentence thereby ruining the justification of the paragraph.

Thanks

Change History

comment:1 Changed 5 years ago by garry.yao

  • Keywords Pending added

Works for me, could you please provide more details?

comment:2 Changed 5 years ago by fredck

  • Description modified (diff)

comment:3 Changed 5 years ago by fredck

I'm not able to reproduce this issue in any way also. I think something is missing in the TC. Please let us know.

comment:4 Changed 5 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy