Ticket #4675 (closed Bug: invalid)

Opened 5 years ago

Last modified 19 months ago

Remove Format does not reduce block level headings to normal text

Reported by: damo Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (CKEditor) - OLD
Keywords: IBM Discussion Cc: JoeK

Description

When Remove Format is applied to block level headings, they are not reduced to the default text.

When custom styles such as "Blue Title" are applied to some text and then the Remove Format feature is used, the color from the style is removed, but the heading is not. This seems inconsistent.

Change History

comment:1 Changed 5 years ago by garry.yao

  • Keywords Discussion added
  • Version set to SVN (CKEditor)
  • Milestone CKEditor 3.1 deleted

It's by design, while we could put the feature you implied here on discussion.

comment:2 Changed 5 years ago by garry.yao

Fore reference, MS-Word seems to cleanup block styles on 'Remove Format' command.

comment:3 Changed 3 years ago by garry.yao

Below is how MS Word present the clear format command, and it actually remove/deconstruct any styles/structure.

Clear all the formatting from selection, leaving only the plain text.

comment:4 Changed 19 months ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to invalid

Remove format command is used to remove inline styles and not block elements. This is by design and this is how it works in CKEditor 3.x and works now in CKEditor 4.x. I don't think it will changed thus I'm closing this issue.

What we rather have in mind is making removeFormat work like Pasteformword with removeStyles - http://dev.ckeditor.com/ticket/9306.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy