Ticket #4728 (closed Bug: expired)

Opened 5 years ago

Last modified 3 years ago

Bug: Predefined content gone on refresh (F5) in firefox

Reported by: Gabe Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0.1
Keywords: Cc:

Description

happens to me only in firefox. when there is content in the textarea and the CK editor loads, it is the fine the first time. Then when pressing refresh, like F5, or the button in the toolbar, the content is gone. white space.

when loading the page by default (not clicking refresh) it reappears again.

also, when the content is gone, you can click source and source again to switch back and the content is back again!

this bug is also present on the demo CKeditor on your frontpage...

Attachments

ckeditor_bug.jpg (147.4 KB) - added by Gabe 5 years ago.
before/after refresh (F5)

Change History

Changed 5 years ago by Gabe

before/after refresh (F5)

comment:1 Changed 5 years ago by fredck

  • Keywords WorksForMe added; refresh, content, bug, f5, firefox, mozilla removed
  • Priority changed from High to Normal
  • Component changed from Core : Output Data to General
  • Milestone CKEditor 3.2 deleted

You have assigned "CKEditor 3.0 Beta" in the version field for this ticket. I remember we had this kind of issue earlier, but I'm not able to reproduce it anymore with the trunk, the 3.0 or the 3.0.1.

Can you please confirm you're having this issue with the beta only?

comment:2 Changed 5 years ago by Gabe

sorry, this was indeed not correct.

the version i am using is "CKEditor 3.0.1, released on 16 October 2009"

however, this bug is also present in the demo on the website of ckeditor.

comment:3 Changed 5 years ago by Gabe

  • Version changed from CKEditor 3.0 Beta to 3.0.1

comment:4 Changed 5 years ago by fredck

I'm not able to reproduce this issue in any way. Could someone else confirm it?

@Gabe, do you have it in other computers with the same browser. Btw, which Firefox version?

comment:5 follow-up: ↓ 6 Changed 5 years ago by Gabe

thought it was on other computers as well, but it seems to work just fine on another computer with the same version of firefox so it is only my computer... (Firefox 3.5.5, plugins: adblock+,colorzilla,greesemonkey,htmlvalidator,live http headers,measureit,stumbleupon,web developer)

so its fixed now :) thanks anyway

comment:6 in reply to: ↑ 5 Changed 5 years ago by fredck

Replying to Gabe:

thought it was on other computers as well, but it seems to work just fine on another computer with the same version of firefox so it is only my computer... (Firefox 3.5.5, plugins: adblock+,colorzilla,greesemonkey,htmlvalidator,live http headers,measureit,stumbleupon,web developer)

so its fixed now :) thanks anyway

Thanks for the details Gabe. You may try disabling the plugins to check if and which may be causing this issue. Let us know if you have anything from it. Thanks!

comment:7 Changed 5 years ago by Gabe

yes even in safe mode this bug is present. But as long as it is only this computer i will be fine with it.

when i find another computer i will let you know.

comment:8 Changed 5 years ago by windsurfer

Hi, I have the same problem in Firefox 3.0.11 with plugins: CSS Validator, CSS Viewer, FEBE, Firebug, FirePHP, Html Validator, Page Validator and Web developer.

After refresh of page with ckeditor there's no content in editor and furthermore I'm not able to write anything (there is no focus on editor even when i'm clicking on it).

I'm also able to clik Source and click it again. After that everything works OK. I thing there would be some conflict with Mozilla plugins.

comment:9 Changed 5 years ago by windsurfer

I found that this problem occurs only when using the Kama skin. With Office2003 skin everything works fine. Maybe there's some bug in Kama skin script.

comment:10 Changed 5 years ago by fredck

@windsurfer, can you try disabling your plugins to check if any of them is disturbing the editor?

comment:11 Changed 5 years ago by windsurfer

I have disabled all plugins, but problem still presists. Even in safe mode.

comment:12 Changed 5 years ago by alfonsoml

What's your OS? Have you tried with Firefox 3.6?

If we can't reproduce the problem, then we can't fix it and I don't remember other people reporting this issue.

comment:13 Changed 4 years ago by windsurfer

The problem occured while I was using Windows XP. Now I'm using windows 7 and Firefox 3.6 and the problem disappeared. I could try it with windows xp and frefox 3.6 in next days. The problem also disappeared after selecting another than basic Kama skin.

comment:14 Changed 4 years ago by djboca

Sorry to open up an old issue but this same problem is occurring with my Firefox installation.

Windows 7 sp1 Firefox 4.0

All addons disabled

Can't put focus in textarea until I click on the source button.

I've changed the skin to office2003 but no luck there either.

comment:15 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy