Ticket #482 (closed Bug: invalid)

Opened 8 years ago

Last modified 7 years ago

FCKConfig.DisableObjectResizing only effective in the main editor's window

Reported by: najcik Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

There's a configuration option: FCKConfig.DisableObjectResizing = false; The problem is that setting it to true only prevents users from the online resizing of an image in the editor main window - if you choose image's properties dlg from the context menu you can still scale it whatever way you want by setting its width and height.

Change History

comment:1 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to invalid

That is actually the correct way of it to work. That setting is intended to prevent users from using the "size handlers" to resize images and tables. It will not prevent users resizing through dialog boxes. They can also use the source view to change sizes, and there is no way to prevent it.

If you need to disable those fields in the dialog, you have to change the dialog page, or even create a plugin to override that dialog.

For version 3.0, we will be discussion generic ways to customize dialogs by using configuration options.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy