Opened 6 years ago

Closed 6 years ago

#4822 closed Bug (fixed)

[IE] Applying 'Headers' to existing table does not work

Reported by: pomu0325 Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Dialogs Version: SVN (CKEditor) - OLD
Keywords: Confirmed Review+ Cc: pomu@…

Description

To Reproduce

  • Open CKEditor sample
  • Click 'table' button from toolbar
  • Just click OK to add a new table
  • Right click inside of first cell and select table properties
  • Change 'Headers' from 'None' to 'First Row'
  • Click OK
  • Then, 'invalid argument' error occurs at l.982 of selection/plugin.js, and whole content is removed from editor!

Attachments (1)

4822.patch (865 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by garry.yao

  • Component changed from General to UI : Dialogs
  • Keywords Confirmed Review? added
  • Milestone set to CKEditor 3.1
  • Owner set to garry.yao
  • Status changed from new to assigned

Since certain operation from the table properties dialog modifies the table structure, we should have the original selection well-protected.

Changed 6 years ago by garry.yao

comment:2 Changed 6 years ago by pomu0325

  • Keywords Review+ added; Review? removed

It worked, thanks for quick fix.

comment:3 Changed 6 years ago by fredck

  • Keywords Review? added; Review+ removed

@pomu0325, the review processes is to be performed by the core development team. Thanks anyway for you effort, as the patch is definitely good.

comment:4 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:5 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4786].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy