Opened 6 years ago

Closed 6 years ago

Last modified 18 months ago

#4892 closed Bug (fixed)

[IE] Paste: Table alignment is being applied to table content

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: Plugin : Paste from Word Version:
Keywords: IBM Confirmed Review+ Cc:

Description

Tables with an explicit alignment set are pasted with a wrapping div to set that alignment. When the alignment is center or right, various problems are encountered after pasting.

  1. All content inside cells is aligned according to the wrapping div's align setting i.e. center or right.
  1. The option to set specific paragraph alignment in a cell to left is not enabled or not possible. Although, it is possible to set center, right and justify.

Reproduced in IE 6 & 7.

Attachments (1)

4892.patch (1.5 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by garry.yao

comment:1 Changed 6 years ago by garry.yao

  • Keywords Confirmed Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

There's a reason behind M$'s using <div align="right"> to represent right-aligned block that it doesn't cause following text to surround the table, while a table is setting to allow text surrounding in MS-Word, align will just get applied on the table instead.
But the problem damo described here is still valid, since IE inherit the div's alignment into table cells. Proposing a fix that works for both cases.

comment:2 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:3 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4838].

comment:4 Changed 18 months ago by fredck

  • Component changed from Core : Pasting to Plugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy