Opened 6 years ago

Closed 6 years ago

#4898 closed Bug (fixed)

Paste: After pasting a table from word it is not possible to navigate outside the table

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed IE IBM Review+ Cc:

Description

After inserting a table using the paste function, it is not possible to navigate out of the table and continue editing the document.

Reproduced in FF.

Attachments (2)

test.doc (24.0 KB) - added by damo 6 years ago.
4898.patch (2.5 KB) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by garry.yao

  • Component changed from General to Core : Pasting
  • Keywords Pending added
  • Milestone CKEditor 3.1 deleted

WFM, could you attach a sample document for reproducing?

Changed 6 years ago by damo

comment:2 Changed 6 years ago by damo

Added a test doc.

To reproduce select only the table without selecting any content outside the table and copy + paste.

Reproduced in IE 7. Seems to be OK in FF 3.

comment:3 Changed 6 years ago by fredck

  • Keywords Confirmed IE added; Pending removed
  • Milestone set to CKEditor 3.3

Hum... I'm a bit confused. The original report says it's confirmed with FF. Now, it's ok with FF, but buggy with IE.

Anyway... confirmed with IE8. The padding paragraph never gets created, so we can't move after the table.

comment:4 Changed 6 years ago by garry.yao

  • Version set to SVN (CKEditor)

Similar with #3336, the table was result inside the existing paragraph, the cure is to have special treatment in 'insertHtml'.

comment:5 Changed 6 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

Changed 6 years ago by garry.yao

comment:6 Changed 6 years ago by garry.yao

  • Component changed from Core : Pasting to General
  • Keywords Review? added
  • Milestone changed from CKEditor 3.4 to CKEditor 3.3
  • Owner set to garry.yao
  • Status changed from new to assigned

Before correcting the 'insertHtml' behavior, we could still find a fix in our padding body logics to deal with such special case.

comment:7 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:8 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5284].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy