Ticket #4918 (closed Bug: fixed)

Opened 5 years ago

Last modified 5 years ago

FF: Switching to source view when editor maximized

Reported by: tobiasz.cudnik Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.1
Component: UI : Toolbar Version: SVN (CKEditor) - OLD
Keywords: Firefox Confirmed Review+ Cc:

Description (last modified by tobiasz.cudnik) (diff)

When switching to source view (back and forth) when editor is maximized, there is toolbar icons relocation for short period of time. They are displayed vertically on the left side of the editor.

Please refer to attached screenshot.

Reproduced in LTR quirks with FF2 (stronger effect) and FF3 using Office2003 and V2 skins. Kama skin is not affected.

Attachments

2009-12-29-115701_211x247_scrot.png (3.4 KB) - added by tobiasz.cudnik 5 years ago.
4918.patch (968 bytes) - added by garry.yao 5 years ago.

Change History

Changed 5 years ago by tobiasz.cudnik

comment:1 Changed 5 years ago by tobiasz.cudnik

  • Description modified (diff)

comment:2 Changed 5 years ago by fredck

  • Keywords Confirmed added

Note that what you're seeing there are not the icons of the maximized editor but the icons from other editors in the page (you're probably using the skins sample to check it). When maximized, the editor changes the structure of the entire page behind it to avoid scrollbars and other undesired effects.

The solution for it would be forcing a white background in the contents space. This should be done through the skin CSS though, so one can change it to other colors or even remove the color at all (to have a transparent editor).

Strangely, this is not an issue with the 3.0.2, so it's worth understanding which changeset introduced it.

comment:3 Changed 5 years ago by tobiasz.cudnik

You're right, those are icons from another editor, with different skin.

Changed 5 years ago by garry.yao

comment:4 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Keywords Review? added
  • Status changed from new to assigned

Strangely, this is not an issue with the 3.0.2

Confirmed with 3.0.2 also, just not affecting Kama skin.

comment:5 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:6 Changed 5 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [4849].

comment:7 Changed 5 years ago by tobiasz.cudnik

  • Keywords Review- added; Review+ removed
  • Status changed from closed to reopened
  • Resolution fixed deleted

There is still such an effect when switching from source to wysiwyg when editor is maximized. Affected is FF3 and both Office2003 and V2 skins. On FF2, switching TO source view is also a problem.

comment:8 Changed 5 years ago by tobiasz.cudnik

  • Status changed from reopened to closed
  • Keywords Review+ added; Review- removed
  • Resolution set to fixed

This was some unknown issue on my side. Now i can't reproduce it anymore. Closing.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy