Ticket #4945 (closed Bug: fixed)

Opened 5 years ago

Last modified 3 years ago

Paste: Outline Numbered list do not copy correctly v2

Reported by: damo Owned by: paho
Priority: Normal Milestone:
Component: Core : Pasting Version: SVN (CKEditor) - OLD
Keywords: IBM Cc: JoeK

Description

Lists with more than 2 levels and that have the style "Outline Numbered" do not paste correctly. Levels beyond the 2nd level collapse.

This is not dependant on the measurement units applied. Very similar #4896

See tc document attached:OutlineNumberedList2.doc

Attachments

OutlineNumberedList2.doc (20.0 KB) - added by damo 5 years ago.
ListStyleUsedForTC.png (10.8 KB) - added by damo 5 years ago.
4945.patch (1.7 KB) - added by paho 4 years ago.
Patch
4945_2.patch (2.9 KB) - added by garry.yao 4 years ago.

Change History

Changed 5 years ago by damo

comment:1 Changed 5 years ago by garry.yao

  • Keywords Confirmed added
  • Version set to SVN (CKEditor)

Confirmed, while for this specific list structure we've been unable to infer the correct indentation of level3, we're not able to fix it right now, leave it open for investigation.

comment:2 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.1 to CKEditor 3.x

comment:3 Changed 5 years ago by damo

  • Keywords IBM added

comment:4 Changed 5 years ago by damo

The steps to create this particular document are quite basic. Because this list is so easy to create, it may be encountered by many users using the paste feature.

I've provided a screen shot of the default list style that is applied, as it appears in Word.

Changed 5 years ago by damo

comment:5 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:6 Changed 4 years ago by paho

  • Status changed from confirmed to assigned
  • Owner set to paho

comment:7 Changed 4 years ago by paho

When we copy and paste text from word, copied data sometimes looks like:

<OL>
	<LI>1.	First Line- Level 1</LI>
	<LI>2.	Second Line- Level 1</LI>
	<OL>
		<LI>a.	First Line- Level 2</LI>
		<LI>b.	Second Line- Level 2</LI>
		<OL>
			<LI>i.	First Line- Level 3</LI>
			<LI>ii.	Second Line- Level 3</LI>
		</OL>
	</OL>
	<LI>4.	Third Line- Level 1</LI>
	<LI>5.	Fourth Line- Level 1</LI>
</OL>

and sometimes like:

<P>1.	First Line- Level 1</P>
<P>2.	Second Line- Level 1</P>
<P>a.	First Line- Level 2</P>
<P>b.	Second Line- Level 2</P>
<P>i.	First Line- Level 3</P>
<P>ii.	Second Line- Level 3</P>
<P>4.	Third Line- Level 1</P>
<P>5.	Fourth Line- Level 1</P>

with many different attributes of course (like margins, fonts, etc).

The problem is, when sometimes data copied from word is mixed and looks like:

<OL>
	<LI>1.	First Line- Level 1</LI>
	<LI>2.	Second Line- Level 1</LI>
	<OL>
		<LI>a.	First Line- Level 2</LI>
		<LI>b.	Second Line- Level 2</LI>		
	</OL>
</OL>
<P>i.	First Line- Level 3</P>
<P>ii.	Second Line- Level 3</P>
<OL>
	<LI>4.	Third Line- Level 1</LI>
	<LI>5.	Fourth Line- Level 1</LI>		
</OL>

comment:8 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to wontfix

@paho Nice explanatory, we'll not be able to provide any fixing here as there will never have enough evidence for us to infer the indent level of such middle paragraphs.

Changed 4 years ago by paho

Patch

comment:9 Changed 4 years ago by garry.yao

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Pawel's patch proposed a possibility to fix such cases, confirmed in both 2007 and 2010, where 'tab-stops' is presented on <li> to help us analysis the indentation level of following list items that are presented in paragraph. Unfortunately this indicator doesn't appear in version 2003 but anyway it would be good to have it.

I'm now simplifying the patch one step future to make it better to understand.

Changed 4 years ago by garry.yao

comment:10 Changed 4 years ago by paho

  • Status changed from reopened to review

comment:11 Changed 4 years ago by garry.yao

  • Status changed from review to assigned

Currently blocked by #6662.

comment:12 Changed 4 years ago by garry.yao

#6493 has been marked as a DUP.

comment:13 Changed 4 years ago by wwalc

It looks like it can be closed after closing #7131

comment:14 Changed 4 years ago by satya

This is fixed. please close the defect.

comment:15 Changed 3 years ago by Saare

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy