Ticket #5069 (closed Bug: expired)

Opened 5 years ago

Last modified 5 years ago

Panels are not working with IE in RTL page

Reported by: fredck Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Floating Panel Version: SVN (CKEditor) - OLD
Keywords: IE Oracle Cc: Senthil, Pranav

Description

  1. In an editor sample, add direction="rtl" to the <html> tag.
  2. Load the sample in IE8 in Compatibility mode, or IE7.
  3. Click any of the panels, or open the context menu.

The floating panel will not be visible.

Note also that the page have an unwanted horizontal scrollbar. This is not an issue in IE8 mode and not even with other browsers.

Change History

comment:1 Changed 5 years ago by fredck

Of course, the same problem happens in IE8 mode if the page is in quirks.

comment:2 Changed 5 years ago by fredck

  • Cc Senthil, Pranav added
  • Keywords Oracle added

#5063 has been marked as DUP, where the reporter also confirms it in IE8 mode.

comment:3 Changed 5 years ago by garry.yao

  • Keywords Pending added; Confirmed removed

I was unable to reproduce the panel invisible problem on trunk in any case.

Note also that the page have an unwanted horizontal scrollbar. This is not an issue in IE8 mode and not even with other browsers.

The vertical scrollbar applied to the entire page is not related to the editor, it's still there if we create no editor instance.

comment:4 follow-up: ↓ 5 Changed 5 years ago by garry.yao

  • Keywords Pending removed
  • Status changed from new to closed
  • Resolution set to expired

Feel free to reopen the ticket on any new discoveries.

comment:5 in reply to: ↑ 4 Changed 5 years ago by pranav

  • Status changed from closed to reopened
  • Resolution expired deleted

Replying to garry.yao:

Feel free to reopen the ticket on any new discoveries.

I varified in latest nightly build and I was not able to reproduce it. However the problem is there in our code line of ckeditor 3.1 at revision number 5018. I am re-opening this ticket to get a patch fixing this problem in our code line.

comment:6 Changed 5 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to expired

Please don't reopen closed ticket for above purpose, use our support channel instead.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy