Ticket #5156 (closed Bug: fixed)

Opened 5 years ago

Last modified 14 months ago

Focus goes into body before activating dialog

Reported by: damo Owned by:
Priority: Normal Milestone:
Component: Accessibility Version: 3.0
Keywords: IBM Cc:

Description

When JAWS is on and the user presses space bar to activate the dialogs from the toolbar, the cursor is going in to the body of the editor before focus goes in to the dialog. So JAWS is reading the help text for Editor body and then the focus element on the dialog.

This will confuse the blind user.

Change History

comment:1 Changed 5 years ago by fredck

  • Keywords Pending added

I'm not able to reproduce it, but it may depend on the connection speed, and the amount of time it takes for the dialog to be created and focused.

I've made changes with [5140] that could bring changes here, at least for non IE browsers. Can you try it in the 3.2.x branch and see the results?

comment:2 Changed 5 years ago by damo

This is ok for most dialogs now, except for the paste as plain text and paste from word dialogs.

comment:3 Changed 5 years ago by fredck

  • Keywords Pending removed
  • Milestone changed from CKEditor 3.2 to CKEditor 3.3

Any change to the pasting system would be risk at this point. We need to investigate alternative ways to avoid JAWS announcing temporary focus.

comment:4 Changed 5 years ago by garry.yao

  • Milestone changed from CKEditor 3.3 to CKEditor 3.x

comment:5 Changed 5 years ago by damo

Why was this one moved out to 3.x? The risk Fred referred to was the 3.2 release not 3.3.

comment:6 Changed 5 years ago by fredck

Right now we don't have much to do here due to browsers limitations. It would be interesting to hear from FS if there is any way to temporarily block JAWS from announcing thigs. In this way we could quickly block it before setting the selection in the editor, unblocking it as soon as the focus is set into the dialog.

comment:7 Changed 5 years ago by garry.yao

Safari now shows regression of [5140]:

Environment

Safari

Reproducing Procedures

  1. Open any of the sample page;
  2. Open 'Link' dialog without focusing editor.
    • Actual Result: JavaScript error thrown.

I've converted the changes for Webkit with [5377].

comment:8 Changed 4 years ago by fredck

  • Milestone CKEditor 3.x deleted

Milestone CKEditor 3.x deleted

comment:9 Changed 2 years ago by j.swiderski

  • Status changed from new to confirmed
  • Version changed from SVN (CKEditor) - OLD to 3.0

I have just checked this issue in CKEditor 3.6.3 and JAWS 13 and it still occurs.
Tested in Firefox 12.

To reproduce:

  1. Clear browsers cache and press CRTL+F5 few times.
  2. TAB to content area of the editor
  3. Press Alt+F10 and navigate with tabs and arrows to "paste from word" button
  4. JAWS will read first "Richtext editor, editor, one. Press alt+0 for help ..." and then Paste dialog information.

Reproducible From CKEditor 3.0

comment:10 Changed 14 months ago by mgifford

Can you test it again in CKEditor 4.3? It's been 18 months and would be good to know if this is still an active issue.

comment:11 Changed 14 months ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to fixed

Issue is no longer reproducible in editor 4.x. Focus goes for a moment into editor but its contents aren't read. I'm closing it as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy