Opened 7 years ago

Closed 7 years ago

#5182 closed Bug (fixed)

Context menu is not read as a context menu by JAWS

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: Accessibility Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Review+ Cc: Joek

Description

When displaying context-menus and sub-menus JAWS does not read the menus as menus, just the general label "Options". When using a toolbar menu (scayt), JAWS reads "Menu Options" and when leaving the menu it says "Leaving menu".

In earlier versions, JAWS would actually read "Context menu"

Attachments (2)

5182.patch (1.5 KB) - added by garry.yao 7 years ago.
5182_2.patch (1.7 KB) - added by garry.yao 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by fredck

  • Keywords Pending added

Here we have some limitations with JAWS. In fact, if you open the context menu and hit INSERT+ESC to refresh the screen, the next time you open the context menu it will be reas just like you have described it for SCAYT.

JAWS reads:

  1. "Applications" (???)
  2. "Menu"
  3. "Options" (note that's not "Menu Options")
  4. "To move through options press UP and DOWN arrow"

If we remove "Options", FF will provide JAWS a strange URL which is read, and this is undesirable. I can't understand the "Applications" thing.

Then on ESC to close the menu, it reads "Leaving menus", as expected.

Ideally JAWS should read: "Menu", "To move through options press UP and DOWN arrow". Maybe FS can give us some idea on how to achieve this.

comment:2 Changed 7 years ago by damo

The proposal here is to provide a label of "Context" instead of "Options" for the context menu.

Changed 7 years ago by garry.yao

comment:3 Changed 7 years ago by garry.yao

  • Component changed from General to Accessibility
  • Keywords Confirmed Review? added; Pending removed
  • Owner set to garry.yao
  • Status changed from new to assigned

comment:4 Changed 7 years ago by fredck

  • Keywords Review- added; Review? removed

The proposed idea makes sense. The implementation makes the API dirty though, and also complicated as the entire definition must be passed even if we want to change just a single attribute on it.

At this point, we could instead make the CKEDITOR.plugins.contextMenu::_.defintion and public property, renaming it to CKEDITOR.plugins.contextMenu::definition. In this way the attribute can be easily changes right after creating the class instance.

Changed 7 years ago by garry.yao

comment:5 Changed 7 years ago by garry.yao

  • Keywords Review? added; Review- removed

comment:6 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:7 Changed 7 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5283].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy