Opened 5 years ago

Closed 5 years ago

#5232 closed Bug (fixed)

[[IE]]—Bold Italic Underline Strikethrough Subscript and Superscript options are sticky even after we clicked on the options to undo them

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.0.2
Keywords: IBM Confirmed Review+ Cc: damo, joek

Description

To reproduce the defect:

1) open the Ajax sample
2) Click on Bold icon
3) Type some characters,see that they are typed in Bold.
4) Click on Bold Icon again to remove the Bold option
5) See that the Bold options is removed.
6) Now click on any of the other Formatting icons (Italic,Underline,StrikeThrough,Subscript,Superscript).
7) See that Bold Icon is also selected.
8) Same thing happens with all the other icons.

Reproduced in IE6 & IE7

Attachments (1)

5232.patch (929 bytes) - added by garry.yao 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by fredck

  • Keywords Confirmed added
  • Milestone changed from CKEditor 3.2 to CKEditor 3.3
  • Version changed from SVN (CKEditor) to 3.0.2

Confirmed with IE8 compatibility mode also. Works well in IE8 mode and with FF.

Introduced with CKEditor 3.0.2.

comment:2 Changed 5 years ago by garry.yao

  • Owner set to garry.yao
  • Status changed from new to assigned

comment:3 Changed 5 years ago by garry.yao

I can locate the regression to [4774] while was unable to locate the bug :/

comment:4 Changed 5 years ago by garry.yao

  • Keywords Review? added

The real regression is proved to be [4755], proposing of reverting that fix since it's not able to reproduce anymore #4848 on trunk probably due to [4563].

Changed 5 years ago by garry.yao

comment:5 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:6 Changed 5 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5298].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy