Ticket #5242 (closed Bug: fixed)

Opened 4 years ago

Last modified 4 years ago

Text and Background Colour applied to the text are removed together even though we removed only one of Text Colour or Background Colour

Reported by: satya Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: Core : Styles Version: SVN (CKEditor) - OLD
Keywords: IBM Confirmed Review+ Cc: damo,joek

Description

To reproduce the defect:

  1. open the Ajax sample.
  1. Click on Text Colour button menu and select some colour(eg: red).
  1. Click on Background Colour button menu and select some colour(eg: cyan).
  1. Type the text see that both the Text and Back ground colour's that we have selcted in steps 2 & 3 is applied to the text.
  1. Now click on Text Colour button and select the Automatic Colour Option to remove the Text Colour.
  1. Type some more text.
  1. See that both Text Colour as well as Background colour applied to the text is removed.

Expected Result:

Only the Text Colour should be removed and the Background colour should remain.

Same behaviour appears when we remove Background Colour insted of Text Colour in step 5.

Attachments

5242.patch (2.3 KB) - added by garry.yao 4 years ago.
5242_2.patch (1.4 KB) - added by garry.yao 4 years ago.

Change History

comment:1 Changed 4 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao
  • Version changed from 3.1 to SVN (CKEditor)
  • Component changed from General to Core : Styles
  • Keywords Confirmed added

Changed 4 years ago by garry.yao

comment:2 Changed 4 years ago by garry.yao

  • Keywords Review? added

The 'Automatic' color options works now by using a hack that an empty color style (single span without any attributes) could matches all fore and background colors, but obviously this's cumbersome, since it will incorrectly remove the one other when applying, so introduce here a new approach.

comment:3 Changed 4 years ago by fredck

  • Keywords Review+ added; Review? removed

Interesting idea.

comment:4 Changed 4 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5265].

comment:5 Changed 4 years ago by satya

  • Status changed from closed to reopened
  • Resolution fixed deleted

In IE6 and IE7 this is still re producible.

Changed 4 years ago by garry.yao

comment:6 Changed 4 years ago by garry.yao

  • Keywords Review? added; Review+ removed

New patch that targeting IE6/7.

comment:7 Changed 4 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:8 Changed 4 years ago by garry.yao

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with [5291].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy