Ticket #5257 (closed Bug: fixed)

Opened 4 years ago

Last modified 2 years ago

Adding row to rowspaned table breaks layout

Reported by: jpkuitunen Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.1
Keywords: Cc:

Description

Reproduce

  • Add new 2*2 table
  • Right-click first cell and merge it down
  • Right click merged cell and add a row below

For an alternative sort of explosion, trigger the row addition from the second cell of the second row.

Result

Either extra colspans and cells are added or cells are missing, depending on where you trigger the row addition.

Expected result

A new row,

<tr><td></td></tr>

We have had this problem with the latest stable FCKEditor also and now since cell mergers are supported in CKEditor, the same problems persist.

There are some tickets concerning the issue filed agains FCKEditor:
http://dev.fckeditor.net/ticket/2859
http://dev.fckeditor.net/ticket/2813
http://dev.fckeditor.net/ticket/2656

Change History

comment:1 Changed 3 years ago by wwalc

  • Component changed from Core : Output Data to Core : Tables

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to expired

This ticket is no longer reproducible in latest CKEditor 3.6.2

comment:3 Changed 2 years ago by j.swiderski

  • Status changed from closed to reopened
  • Resolution expired deleted

comment:4 Changed 2 years ago by j.swiderski

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy