Opened 7 years ago

Closed 7 years ago

#5266 closed Bug (fixed)

Table headers incorrectly displayed when SCAYT is enabled

Reported by: wwalc Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: SVN (CKEditor) - OLD
Keywords: Confirmed Cc: SpellChecker.net

Description

When SCAYT is disabled, two <th> cells are displayed just like if there was one cell. Confirmed in Safari 4 and FF 3.5.8.

Steps to reproduce

  • enable SCAYT
  • switch to source mode, paste the following code:
    <table>
                    <tr>
                                    <th>
                                                    hello
                                    </th>
                                    <th>
                                                    world
                                    </th>
                    </tr>
                    <tr>
                                    <td>text 1</td>
                                    <td>text 2</td>
                    </tr>
    </table>
    
  • switch to wysiwyg mode
  • result: look at the header, it looks like if there was <th>hello world </th> (when switching back to source mode, the code is fine, it just looks strange)

Change History (4)

comment:1 Changed 7 years ago by wwalc

Probably the problem is that when SCAYT is enabled, the code in the editor looks like this:

<tr>
<span scaytid="6" scayt_word="helloworld">
<th>hello</th>
<th>world</th>
</span>
</tr>

(note the span tag surrounding headers)

comment:2 Changed 7 years ago by garry.yao

  • Milestone set to CKEditor 3.3
  • Version changed from 3.0 to SVN (CKEditor)

Raising the priority of this ticket.

comment:3 Changed 7 years ago by SpellChecker.net

Addressed with patch 5145_7. The patch switch editor to newer version of SCAYT core where the problem is resolved.

comment:4 Changed 7 years ago by fredck

  • Resolution set to fixed
  • Status changed from new to closed

I confirm it's working well now. Changelog entry add with [5323].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy