Ticket #5273 (closed Bug: invalid)

Opened 4 years ago

Last modified 4 years ago

Language tool is substituting 'false' for some existing values.

Reported by: JoeK Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2
Keywords: IBM Cc: damo

Description

  1. Goto the a11yhelp plugin's en language file.
  2. Copy the accessibilityHelp object to the clipboard.
  3. Open the main en language file in the lang folder.
  4. Add a comma to the end of the last lang object.
  5. Paste in the accessibilityHelp object.
  6. Run the langtool to process the file.
  7. Open the de language file.

Observe the accessibilityHelp object has property values set to 'false' with the comment MISSING.

If you remove the white-spaces between the open curly bracket and the 'name' property, their values will be copied to the other language files. For example:

legend :

[ {name : 'General',

items : [

{name : 'Editor Toolbar',

I've also seen this occur if a block comment is entered between the language property value and trailing comma. For example:

url: 'URL' /* block comment */,

Change History

comment:1 Changed 4 years ago by damo

  • Milestone set to CKEditor 3.3

comment:2 Changed 4 years ago by garry.yao

  • Priority changed from High to Normal

comment:3 Changed 4 years ago by fredck

  • Status changed from new to closed
  • Resolution set to invalid
  • Milestone CKEditor 3.3 deleted

The a11yhelp language file has not been designed for compatibility with the langtool and it's not compatible with it. This is by design, and it's related to the arrays included in the language entries.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy