Ticket #5302 (closed New Feature: fixed)

Opened 5 years ago

Last modified 5 years ago

enterMode=ENTER_P is not respected when inside a DIV

Reported by: damo Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Enter Key Version:
Keywords: IBM Confirmed Review+ Cc:

Description

To reproduce:

Add the following source:

<div>Test Value</div>

Then attempt to add new lines to the content.

<div>Test Value</div>
<div>Test Value</div>

New DIV elements are added instead of P elements as set in configuration.

The expectation is that with enterMode=ENTER_P that a new paragraph be added after the DIV.

<div>Test Value</div>
<p>Test Value</p>

This is more than an inconvenience to users now as we provide styled components in the editor content that are made up of DIV elements, that we don't want to be copied whenever a user uses the Enter key after the div.

Attachments

5302.patch (1.3 KB) - added by garry.yao 5 years ago.

Change History

comment:1 Changed 5 years ago by garry.yao

#2403 is the v2 ticket for this.

comment:2 Changed 5 years ago by garry.yao

  • Keywords Discussion added
  • Component changed from General to UI : Enter Key
  • Type changed from Bug to New Feature
  • Milestone changed from CKEditor 3.3 to CKEditor 3.4

Defer it as we can at least achieve now this with config.shiftEnterMode=CKEDITOR.ENTER_P, which always force the specified enter block.
Put it under discussion if a config is needed to also force the config.enterMode block.

comment:3 Changed 5 years ago by damo

The proposed work-around isn't very useful because it means that you can no longer have different behavior between enterMode and shiftEnterMode.

In our case we have:

config.enterMode=CKEDITOR.ENTER_P
config.shiftEnterMode=CKEDITOR.ENTER_BR

Unless there is a significant technical reason to move this out to 3.4 we should seriously consider this for the next release.

comment:4 Changed 5 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao
  • Keywords Confirmed added; Discussion removed
  • Milestone changed from CKEditor 3.4 to CKEditor 3.3

Changed 5 years ago by garry.yao

comment:5 Changed 5 years ago by garry.yao

  • Keywords Review? added

comment:6 Changed 5 years ago by fredck

  • Keywords Review+ added; Review? removed

respection ?! :)

Please add the @since 3.2.1 tag to the documentation.

comment:7 Changed 5 years ago by garry.yao

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5286].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy