Ticket #5330 (closed Bug: fixed)

Opened 5 years ago

Last modified 4 years ago

Contextual menu not functionnal in safari, Google Chrome and Firefox 3.6 on Mac

Reported by: neuropix Owned by: alfonsoml
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Context Menu Version: 3.2
Keywords: Confirmed Review+ Cc:

Description

The contextuel menu dont work on FireFox 3.6 for Mac.

Safari 4 and Google Chrome 5 for Mac work the first time. When I want to right click to an other item it's the browser contextuel menu appear.

Mac OS X 10.5.8

Attachments

5330.patch (1.2 KB) - added by alfonsoml 4 years ago.
Proposed patch

Change History

comment:1 Changed 5 years ago by alfonsoml

  • Keywords Pending added
  • Milestone CKEditor 3.x deleted

Works for me. Make sure that you haven't unchecked the checkbox to "allow webpages to disable or replace the context menu"

comment:2 Changed 5 years ago by neuropix

we did some tests.

on one website we are using CKEditor 3,0 and the context menu work properly. however, on a more recent website, we are using CKEditor 3,2, and in this case the context menu that is supposed to happen when you have the mouse focused on the CKEditor instance is not occuring at all. My hunch is that there is something that was changed inside the javascript that is used to call the dynamic replacement of the textarea with the CKEDitor skin. Also, another thing to note is that on the demo website of CKEditor, the context menu is not working either.

on the following browsers, the context menu is problematic:

Google Chrome 5 Safari 4 Firefox 3,6

I am using Mac OSX 10,5,8 for operating system. i have tested it on a PC browser and the context menu is working properly so far, so this leads me to believe that this is only applying to Mac based computers.

comment:3 Changed 5 years ago by alfonsoml

I tested those same browsers in Mac OS X 10.6.2 and it's working fine in all of them.

comment:4 Changed 5 years ago by neuropix

Is there a configuration that could have been changed, or is there an additional setting that needs to be activated, as taking the stock version of CKEditor 3,2. and applying the same method of integration than 3,0 the context menu is not working for me.

the user agent i have for firefox is the following:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.2) Gecko/20100115 Firefox/3.6

for good measure, i just tested on a brand new mac, fresh install with Mac OS X 10.6.2, i upgraded safari to 4.0.5, and it works in safari, however getting firefox 3.6 will not load the context menu with fresh install.

comment:5 Changed 5 years ago by neuropix

something to note.

i am using a had the right click disabled in my system preferences, so to get the contextual menu, i was pressing the CTRL key. i noted that the 1st time i was pressing it and then mouse click, the normal browser menu was showing up, now, keeping the control key pressed and clicking the mouse again, the CKEDitor context menu then shows up.

i am tempted to believe it is due to the control key usage that is causing problems. as using the right click functionality of the mouse makes it work at all times, regardless of which browser i am using.

comment:6 Changed 5 years ago by alfonsoml

  • Keywords Confirmed added; Pending removed
  • Summary changed from Contextuel menu not fonctionnal in safari, Google Chrome and Firefox 3.6 on Mac to Contextual menu not functionnal in safari, Google Chrome and Firefox 3.6 on Mac

Ok, the Ctrl was the missing part, I always get the context menu with two fingers.

Seems that it can be due to #4826, the strange thing for me is the usage of ctrl
meta instead of checking if it's a mac to select the proper key.

Another workaround (besides using a two mouse button or a touchpad) is to set config.browserContextMenuOnCtrl = false;

Changed 4 years ago by alfonsoml

Proposed patch

comment:7 Changed 4 years ago by alfonsoml

  • Keywords Review? added
  • Milestone set to CKEditor 3.3

comment:8 Changed 4 years ago by alfonsoml

  • Owner set to alfonsoml
  • Status changed from new to assigned

comment:9 Changed 4 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:10 Changed 4 years ago by alfonsoml

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [5386]

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy