Opened 9 years ago

Closed 9 years ago

#539 closed Bug (fixed)

FF: if the HTML has a table in it and you right click in the table while in FCKeditor, the cursor jumps to the top of the HTML

Reported by: lizl Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version:
Keywords: Firefox Confirmed Cc: michaelcaplan@…


Only in Firefox, if you have a table in your HTML and then while you are in FCKeditor you right mouse click when your cursor is in the table or table cell, the editor jumps up to the top of the HTML no matter where you were when you clicked.

Wrote to Frederico about this and here is his reply: I was able to create a very simple test case for this bug, based on your pages. In Firefox, if you scroll down the contents and right click inside the table, it will scroll up automatically. If you instead click at the "More text" phrase at the very end, you will have no problems. It only happens if the editor is inside a table, and if you click in a table in the contents. There is no solution for it for now, and no predictions, but this TC is an important step to find out something. Frederico Caldeira Knabben

Attachments (2)

travel newsletter - long lines.htm (7.7 KB) - added by lizl 9 years ago.
html to replicate the problem - scroll down - click in bottom paragraph - jumps to top
FFScrollTopContext.html (1.2 KB) - added by alfonsoml 9 years ago.
testcase from sourceforge

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by fredck

  • Keywords Pending added; table removed

The information you have provided is not enough for this ticket. We need the TC well explained here, otherwise there is no way to reproduce it again.

Can you give me more info about the message I've sent you? At least the date, so I can research it here, trying to understand what we are talking about.

Changed 9 years ago by lizl

html to replicate the problem - scroll down - click in bottom paragraph - jumps to top

comment:2 Changed 9 years ago by lizl

I have attached the HTML with tables that will easily replicate this problem. Just copy the html into the editor, scroll to the bottom, right click - and then you'll jump right up to the top. This is FF only.

The email I received was dated 12/5/06. There was an issue in the old bug tracking db - 1247079 - which I was discussing and that is the same issue as this.

comment:3 Changed 9 years ago by fredck

  • Keywords Confirmed added; Pending removed
  • Milestone set to FCKeditor 2.5

Thanks for the update lizl.

There is one thing to note. This problem doesn't happen in all FCKeditor instances. It depends on the page where FCKeditor is placed in.

For example, it will not be buggy with sample01.html, but the problem can be reproduced in the online demo instead. So, there is something in the page that makes Firefox behave in that way.

I'm targeting this one to 2.5 for investigation.

Changed 9 years ago by alfonsoml

testcase from sourceforge

comment:5 Changed 9 years ago by martinkou

After tracing through the code, I found the culprit to be the line

window.frameElement.parentNode.insertBefore( oIFrame, window.frameElement ) ;

in editor/_source/classes/fckpanel.js.

comment:6 Changed 9 years ago by martinkou

  • Resolution set to fixed
  • Status changed from new to closed

I've implemented a workaround in [547].

The bug's behavior cannot be completely eliminated, however - right clicking on tables in the specified conditions would still cause the editor frame to scroll to the top briefly, after my changes. This is because the scrolling behavior is a browser bug, and we can't make it completely disappear by only changing FCKeditor's code.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy