Ticket #5404 (closed New Feature: fixed)

Opened 4 years ago

Last modified 3 years ago

FillEmptyBlocks in CKEditor 3.x

Reported by: wwalc Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.5
Component: Core : Output Data Version:
Keywords: Cc:

Description

It looks like FillEmptyBlocks option is not available in CKEditor 3.x, thus it is impossible to configure CKEditor to leave empty elements without nbsp; inside of it.

Attachments

5404.patch (3.4 KB) - added by garry.yao 4 years ago.
5404_2.patch (3.7 KB) - added by garry.yao 4 years ago.
5404_3.patch (4.3 KB) - added by garry.yao 3 years ago.
5404_4.patch (4.3 KB) - added by garry.yao 3 years ago.
5404_5.patch (4.3 KB) - added by garry.yao 3 years ago.

Change History

Changed 4 years ago by garry.yao

comment:1 Changed 4 years ago by garry.yao

  • Status changed from new to assigned
  • Owner set to garry.yao
  • Component changed from General to Core : Output Data
  • Keywords Confirmed Review? added
  • Milestone set to CKEditor 3.4

comment:2 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.4 to CKEditor 3.5

comment:3 Changed 4 years ago by fredck

  • Milestone changed from CKEditor 3.4.1 to CKEditor 3.5

Changed 4 years ago by garry.yao

comment:4 Changed 4 years ago by garry.yao

  • Status changed from review to assigned

With the new patch, fillEmptyBlocks config could be even a mediate function that allows fully controlling over empty blocks (a community feature request).

comment:5 Changed 4 years ago by garry.yao

  • Status changed from assigned to review

comment:6 Changed 3 years ago by fredck

  • Status changed from review to review_failed
  • This setting bus be enabled by default.
  • The documentation syntax is wrong (@type doesn't accept description and there is semicolon after @name).

comment:7 Changed 3 years ago by fredck

Btw... the fix is targeted to the 3.5, but it looks like the patch has been made for trunk.

comment:8 Changed 3 years ago by fredck

Also... better to commit #6248 and update the 3.5.x branch before the new patch, to avoid conflicts later.

Changed 3 years ago by garry.yao

comment:9 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review
  • Version 3.0 deleted

comment:10 Changed 3 years ago by Saare

  • Keywords Confirmed removed
  • Status changed from review to review_passed

Two minor things:

  • L517 could be removed.
  • Let's add to the documentation the fact that we're passing our CKEDITOR.htmlParser.element representation there, and not CKEDITOR.dom.element.

Changed 3 years ago by garry.yao

comment:11 Changed 3 years ago by garry.yao

  • Status changed from review_passed to review

comment:12 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review to review_failed

Using following content:

<p>
	foo</p>
<p>
	&nbsp;</p>
<p>
	bar</p>

Second paragraph is not visible and thus not editable inside WYSIWYG area.

Changed 3 years ago by garry.yao

comment:13 Changed 3 years ago by garry.yao

  • Status changed from review_failed to review

You're right, this option should have NO impact on wysiwyg.

comment:14 Changed 3 years ago by tobiasz.cudnik

  • Status changed from review to review_passed

It's OK now, just change the example inside the JSDOC comment, as it causes an error for elements without a class.

comment:15 Changed 3 years ago by garry.yao

  • Status changed from review_passed to closed
  • Resolution set to fixed

Fixed with [6138].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy