Opened 6 years ago

Closed 6 years ago

#5505 closed Bug (fixed)

IE: Insert image throws error

Reported by: brooks Owned by: garry.yao
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.1
Keywords: Confirmed Review+ Cc:

Description

first make sure you are in https environment, and then choose replace by class sample.

reproduce:

  1. click insert image button
  2. in the dialog first tab, enter a image URI in URL
  3. click ok button

confirmed in Firefox3.5 and IE8,win7

Attachments (1)

5505.patch (796 bytes) - added by garry.yao 6 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by fredck

  • Keywords Confirmed added; bug removed
  • Version changed from SVN (CKEditor) to 3.1

WFM with FF3.6.

I can reproduce it with IE8 in all modes. To avoid IE asking for confirmation regarding mixed content, I'm using a https image for testing:

https://www.google.com/intl/en_ALL/images/logo.gif

Confirmed with CKEditor 3.1. Works well with the 3.0.2.

comment:2 Changed 6 years ago by garry.yao

  • Keywords Pending added; Confirmed removed

Can you confirm the error is just caused by editor not gaining focus, perhaps it's has nothing to do with the HTTPS env?

comment:3 Changed 6 years ago by fredck

  • Keywords Confirmed added; Pending removed
  • Summary changed from Insert image throw a error in https environment to IE: Insert image throws error

Confirmed without https also, but the ticket doesn't depend on this confirmation.

Changed 6 years ago by garry.yao

comment:4 Changed 6 years ago by garry.yao

  • Keywords Review? added
  • Owner set to garry.yao
  • Status changed from new to assigned

To reproduce this bug, you need click on 'Ok' before blur the 'URL' field.

comment:5 Changed 6 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:6 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [5384].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy