Ticket #5519 (closed Bug: duplicate)

Opened 4 years ago

Last modified 4 years ago

Bad handling of textareas

Reported by: Saare Owned by:
Priority: Normal Milestone:
Component: General Version: 3.2.1
Keywords: Cc: Chris@…

Description

Tested with IE8 and the demo.

To reproduce

  • Open the demo and clear the content, insert a form and a textarea in it.
  • Click twice on the textarea to edit the content.
  • Write some content and press ENTER.
  • At this point, another textarea is created and focused.
  • Click on the textarea twice again. there are 3 types of this bug:
  1. Put the caret at the end of the textarea's content and press ENTER. A new paragraph is created below.
  2. Put the caret at the start of the text and press ENTER. the first character is being removed and a new paragraph is created above.
  3. Put the caret somewhere else inside the textarea's text and press ENTER. the text after the caret is being moved to another textarea created below.

Attachments

TesxtareBug.jpg (177.4 KB) - added by Christoffer 4 years ago.
Text editor fails to display items after a textarea

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by Christoffer

  • Cc Chris@… added

Changed 4 years ago by Christoffer

Text editor fails to display items after a textarea

comment:2 in reply to: ↑ 1 Changed 4 years ago by Christoffer

I have also found that on saving and then reopening a form using CKeditor, anything defined after a textarea is not displayed within the editor but somehow appears below it. I'm attaching a jpg to demonstrate. I have tried this in IE 8 Chrome and FireFox with the same results in all.

comment:3 Changed 4 years ago by Saare

The reason for your problem was specified in #5518.

comment:4 Changed 4 years ago by Saare

  • Status changed from new to closed
  • Resolution set to duplicate

DUP of #5627.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy