Opened 6 years ago

Closed 6 years ago

#5573 closed Bug (fixed)

SCAYT breaks cursor position after insert image

Reported by: garry.yao Owned by:
Priority: Normal Milestone: CKEditor 3.3
Component: UI : Spell Checker Version:
Keywords: Confirmed Review- Cc: SpellChecker.net

Description

Reproducing Procedures

  1. Open any of the sample page and load the editor with the following content and selection;
    mis^spelled word
    
  2. Enable SCAYT and waiting for SCAYT to be activated.
  3. Insert a Smiley into the cursor position and wait for SCAYT to refresh.
    • Actual Result: Cursor is now blinking at the beginning of the splitted word.
    • Expected Result: Cursor blinks after the inserted image.

Attachments (2)

5573.patch (533 bytes) - added by SpellChecker.net 6 years ago.
5573_2.patch (1.1 KB) - added by SpellChecker.net 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by SpellChecker.net

Seems to be a SCAYT problem and requires review on the spellchecker.net side.

comment:2 Changed 6 years ago by SpellChecker.net

Was tested nightly_build from 04/26/2010 in ff and ie. Problem is not reproduced. We have an "expected result"

comment:3 Changed 6 years ago by garry.yao

Unable to reproduce with the original TC anymore, but still seen for below selection instead:

mis^pelled

comment:4 Changed 6 years ago by SpellChecker.net

confirm

comment:5 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from new to closed

The bug is fixed by recent SCAYT core updates.

Changed 6 years ago by SpellChecker.net

comment:6 Changed 6 years ago by SpellChecker.net

  • Keywords Review? added
  • Resolution fixed deleted
  • Status changed from closed to reopened

The problem related to the focus of editable area when scayt.refresh is called.

comment:7 Changed 6 years ago by garry.yao

  • Keywords Review- added; Review? removed

The fix must be propagated to 'insertHtml' listener also.

Changed 6 years ago by SpellChecker.net

comment:8 Changed 6 years ago by garry.yao

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with [5484].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy