Opened 7 years ago

Closed 7 years ago

#5578 closed Bug (fixed)

Flash with Alignment is not shown properly in Editor body

Reported by: satya Owned by: brooks
Priority: Normal Milestone: CKEditor 3.3
Component: General Version: 3.2
Keywords: IBM Confirmed Review+ Cc: damo, joek

Description

To reproduce the defect:

  1. Open Ajax sample.
  1. Type some text and insert flash with right alignment.
  1. See that flash is inserted in the body of the editor and is shown as aligned to right.
  1. Type some more text and Click on Remove Editor button to save the page.
  1. See that Flash is shown with proper Alignment on Page View.
  1. Click on Create Editor button to open the page and see the Alignment of Flash in the boy of the Editor.

Expected Result:

Flash will be shown on the right hand side of Editor since it's Alignment was set to Right

Actual Result:

Flash is shown with out any Alignment and it is shown in the middle of the text when i check the Flash Alignment in Flash Properties it is showing Alignment correctly as Right

Attachments (3)

5578.patch (579 bytes) - added by brooks 7 years ago.
5578_2.patch (601 bytes) - added by brooks 7 years ago.
5578_3.patch (555 bytes) - added by brooks 7 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 7 years ago by brooks

  • Keywords Confirmed added
  • Owner set to brooks
  • Status changed from new to assigned

Changed 7 years ago by brooks

comment:2 Changed 7 years ago by brooks

  • Keywords review? added

comment:4 Changed 7 years ago by garry.yao

  • Keywords review+ added; review? removed

Ye, let's do that for safe.

comment:5 Changed 7 years ago by brooks

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed with 5414 5414

comment:6 Changed 7 years ago by alfonsoml

  • Keywords Review- added; review+ removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

Due to that checkin now it isn't possible to create a Page Break. In Firefox there's no error, but nothing happens, and in IE8 it throws an error pointing exactly at that line.

Changed 7 years ago by brooks

comment:7 Changed 7 years ago by brooks

  • Keywords Review? added; Review- removed

yes,add align property in
http://dev.fckeditor.net/browser/CKEditor/trunk/_source/plugins/fakeobjects/plugin.js#L67[[BR]] will make page break down.recover it now

comment:8 Changed 7 years ago by garry.yao

  • Keywords Review- added; Review? removed

We benefit with the change that fake element will automatically present alignment of the real element, I believe the problem is with the line itself:

align : realElement.attributes.align || ''
V.S.
align : realElement.getAttribute( 'align' )|| ''

Changed 7 years ago by brooks

comment:9 Changed 7 years ago by brooks

  • Keywords Review? added; Review- removed

nice suggest:-)

comment:10 Changed 7 years ago by garry.yao

  • Keywords Review+ added; Review? removed

There's no changelog needed.

comment:11 Changed 7 years ago by brooks

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed with 5426 5426

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy