Ticket #5615 (closed Bug: wontfix)

Opened 4 years ago

Last modified 11 months ago

IE6 IE7: CKEditor scrolls up when clicked outside editor and config.docType is set

Reported by: amedina5511 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: IE6 IE7 Cc: alex@…

Description

CKeditor 3.2 : setting any value in config.docType makes vertical scrollbar flicker and you can't see the cursor.

  • change the config.docType setting with the same CKeditor default value.

config.docType = '<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.0 TransitionalEN">';

  • Add more than 20 lines so that there is a vertical scrollbar on the right side of the textarea.
  • Select the last line of text in the textarea and try to apply a font size, style, format or font name
  • You will see that the cursor moves (flickers) and you can't see the last line
  • Now, remove the configuration line config.docType in the first step and every works fine.

Attachments

5615.png (1.9 KB) - added by j.swiderski 3 years ago.

Change History

comment:1 in reply to: ↑ description ; follow-up: ↓ 2 Changed 4 years ago by amedina5511

This only occur in IE

Replying to amedina5511:

CKeditor 3.2 : setting any value in config.docType makes vertical scrollbar flicker and you can't see the cursor.

  • change the config.docType setting with the same CKeditor default value.

config.docType = '<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.0 TransitionalEN">';

  • Add more than 20 lines so that there is a vertical scrollbar on the right side of the textarea.
  • Select the last line of text in the textarea and try to apply a font size, style, format or font name
  • You will see that the cursor moves (flickers) and you can't see the last line
  • Now, remove the configuration line config.docType in the first step and every works fine.

comment:2 in reply to: ↑ 1 Changed 4 years ago by amedina5511

Replying to amedina5511:

This only occurs in IE

Replying to amedina5511:

CKeditor 3.2 : setting any value in config.docType makes vertical scrollbar flicker and you can't see the cursor.

  • change the config.docType setting with the same CKeditor default value.

config.docType = '<!DOCTYPE HTML PUBLIC "-W3CDTD HTML 4.0 TransitionalEN">';

  • Add more than 20 lines so that there is a vertical scrollbar on the right side of the textarea.
  • Select the last line of text in the textarea and try to apply a font size, style, format or font name
  • You will see that the cursor moves (flickers) and you can't see the last line
  • Now, remove the configuration line config.docType in the first step and every works fine.

comment:3 Changed 4 years ago by alfonsoml

  • Priority changed from High to Normal

comment:4 Changed 3 years ago by j.swiderski

  • Keywords IE6 IE7 added
  • Status changed from new to confirmed
  • Version changed from 3.2 to 3.0
  • Summary changed from CKeditor 3.2 setting any value in config.docType makes vertical scrollbar flicker and you can't see the cursor. to IE6 IE7: CKEditor scrolls up when clicked outside editor and config.docType is set

I was not able to reproduce those issues mentioned above at least not in IE8 and IE9, however I have found an issue with IE7 and IE6.

To reproduce:

  1. Set on page with CKEditor config.docType = ''
  2. Now close this page if it is open in browser and clear the cache
  3. Open the page
  4. In source mode paste in the below code
    <p>test1</p><p>test2</p><p>test3</p><p>	test4</p><p>test5</p>
    <p>test6</p><p>test7</p><p>test8</p><p>test9</p><p>test10</p>
    <p>test12</p><p>test13</p><p>test14</p><p>test15</p><p>test16</p>
    <p>test17</p><p>test18</p><p>test19</p><p>test20</p><p>test21</p>
    <p>test22</p><p>test23</p>
    
  5. Switch to WYSIWYG and scroll down to last line
  6. Click between line 23 and 22 like it is shown on 5615.png
  7. Cursor should blink next to line 22 or 23
  8. Now click out side the CKEditor

Result: CKEditor will scroll up.

This issue has been reproducible in IE6 and IE7 from CKEditor 3.0.

There is a very similar TC in which you don't have to set config.docType to get the result. I have described it here #8643

Changed 3 years ago by j.swiderski

comment:5 Changed 2 years ago by j.swiderski

Other tickets that concern scrolling problems in IE: #8393, #8643, #8729

comment:6 Changed 11 months ago by Reinmar

  • Status changed from confirmed to closed
  • Resolution set to wontfix

We dropped IE7 support.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy