Opened 5 years ago

Closed 4 years ago

#5633 closed Bug (invalid)

CKeditor 3.2.1 : font type is lost after repeated font type selections.

Reported by: amedina5511 Owned by:
Priority: Normal Milestone:
Component: General Version: 3.0
Keywords: Cc: alex@…

Description

I tested this in CKeditor 3.2.1 and found this issue in both FF and IE.


-select a line in the CKeditor

  • make the font very large (20 or so). This will help you see the problem easier.
  • select "Comic Sans" font type
  • select "Trebuchet MS on the same text selected previously.
  • select "Trebuchet MS" again on the same text selected previously. The font should either stay unchanged or should be "Comic Sans". However, the font is never changed to "Comic Sans".

Change History (3)

comment:1 Changed 5 years ago by alfonsoml

  • Priority changed from High to Normal
  • Resolution set to invalid
  • Status changed from new to closed

That's the expected behavior. It can't remember all the previous styles applied to a selection.

comment:2 Changed 5 years ago by amedina5511

  • Resolution invalid deleted
  • Status changed from closed to reopened

Please confirm that you are indicating that if you apply a font style two times, CKeditor will change the font back to the default font style?

comment:3 Changed 4 years ago by j.swiderski

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Version changed from 3.2.1 to 3.0

dropdown list. Selecting this font-style (in this case it's deselecting) once more will remove it and apply default one.

As @alfonsoml said this is the expected behavior.

Closing the ticket as invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy